Support » Plugin: Asgaros Forum » Private Profile re-direct

  • Resolved wiresandwifi

    (@wiresandwifi)


    Good day.

    I am struggling with the re-direct, when clicking on the username as per the latest posts widget.

    when I click on a public profile, I am shown the member detail as expected.

    However, When I click on a Private profile, I get re-directed to the homepage of the website.

    I obviously do not want to display private profile content.

    Is it possible to not show a private profile as a clickable link, As in, when I click on it, it should do nothing, or maybe show a messgae that indicates this profile is private and not viewable?

    Regards,
    Leon

    [ Please do not bump. ]

    • This topic was modified 2 years, 6 months ago by wiresandwifi.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter wiresandwifi

    (@wiresandwifi)

    Kindly confirm whether this plugin is still supported? I do not want to risk paying for needed add-ons.

    Many thanks, Leon

    • This reply was modified 2 years, 6 months ago by wiresandwifi.
    Plugin Author Asgaros

    (@asgaros)

    Hello @wiresandwifi

    You mentioned that you are using some private-profile-functionality so I guess that this is implemented by using a certain plugin. Which plugin are you using for your profiles?

    Thread Starter wiresandwifi

    (@wiresandwifi)

    My apologies for the late reply. I am using Ultimate Member.
    I figured out the issue. The Edit Profile is re-directing me to the wp-admin and the user role does not have access to wp-admin.

    I need the edit profile to point to
    https://the5thshot.co.za/user/?profiletab=main&um_action=edit
    user-edit.php

    and not the profile edit for wp-admin.

    I must also add, the plugin is great, keep up the good work

    Thread Starter wiresandwifi

    (@wiresandwifi)

    Hey @asgaros
    I found a fix. I actually found it in your Asgaros Support Forum.
    I used the following filter:

    add_filter(‘edit_profile_url’, ‘my_edit_profile_url’, 10, 3);
    function my_edit_profile_url($url, $user_id, $scheme) {
    return home_url(‘/user/’.$user_id);
    }

    It is now no longer using the wp-admin for profile editing, but is using Ultimate Member as expected.

    Is there an option of adding this as a setting in Asgaros Settings? I see a lot of people struggling with this on.

    I consider this issue resolved.

    Cheers,
    Leon

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Private Profile re-direct’ is closed to new replies.