Support » Fixing WordPress » private poste viewable from main page?

  • I want the private posts to show up on the main page as they do in the edit feature sorta like this
    2004/01/30 @ 06:13:29 [ no comments – Private ]
    Protected: testing ? admin (admin)
    This post is password protected. To view it please login.
    is this possible? Any one that can hack or help?

Viewing 11 replies - 1 through 11 (of 11 total)
  • ok this is wierd,
    look at my site
    http://www.hijinks.com/~scott/
    it shows how I want sort of!
    bt when you type the password it doesnt show the post,
    I would also love to be able to let only registered users or some users view these posts.
    Also I have not modified my script only the template.

    ok I am starting to understand this the post password field is what i want!
    why doesnt it work?
    I type the password and the post doesnt show 🙁

    oh, the test protected password is 123

    Are you sure? I’m seeing what looks like a ‘test post’…i.e., fdakf fdkjkd kdf, or whatever. 🙂

    look at it now
    it should look like this
    1/29/2004
    Protected: test
    Filed under:
    General
    ? admin @ 10:45 am
    This post is password protected. To view it please enter your password below:
    Password:
    Enter your password to view comments
    but when the password is typed it does nothing
    if the password is working for you then what should i do to get it to work for me?!?!

    It looked like it worked for me as well. I do think that WP stores a cookie so that next time you visit, the post is auto-unlocked…. could that be what you are experiencing?
    TG

    Yup, you are experiencing the cookie thing. 🙂 If you have put in the password once, it will keep you logged in. The only way to test it is to use a different browser such as Opera or IE if you are logged in under Mozilla. Or clean out your cookies.

    no I put in the password and it still wont show the post

    I’ve posted some posts to a test blog I have and can’t get them to show up when logged in either.

    Have you double checked that you published it? When you go into the advanced options, sometimes it keeps it as a draft vs. publishing it.
    You are just putting it as publish, clicking comments open or closed, clicking pings open or closed and putting in a password?
    I have caught myself in a draft with that. So, please double check! 🙂

    I checked the info right from my database and it was set to ‘private’ and still not viewable when I was logged in. The admin wasn’t even bringing it up when I clicked on the edit screen. I don’t use private posts, so it’s not an issue for me, but I just wanted to make note that I’m experiencing the same problem.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘private poste viewable from main page?’ is closed to new replies.