• Resolved cweb

    (@calebweb)


    When you choose to create a new post, but it is set to “private” it should not broadcast that to Telegram.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hello, we had the same behaviour before but many users requested that they share private posts to private groups, thus wanted those private posts to be sent to Telegram.

    Here is the code needed to prevent them from being sent to Telegram

    /* WP Telegram - do not send private posts */
    add_filter(
      'wptelegram_p2tg_valid_post_statuses',
      function ( $statuses ) {
    
        $key = array_search( 'private', $statuses['live'] );
    
        if ( false !== $key ) {
          unset( $statuses['live'][ $key ] );
        }
    
        return $statuses;
      },
      10,
      1
    );
    /* WP Telegram - do not send private posts */
    

    Add that code to functions.php of your active theme.

    Thread Starter cweb

    (@calebweb)

    I don’t want to add custom code. This is a strange function that at the very least should be optional. What is confusing is if it is “private” mode only the admin can see the post.

    What is confusing is if it is “private” mode only the admin can see the post.

    There can be multiple admins/teams who manage the posts and they want to send posts/progress to their private Telegram groups.

    Thread Starter cweb

    (@calebweb)

    Ok, I understand. Still seems like a strange function that should not set by default.

    I also noticed that by default it also will repost something that had a minor change, even though the checkbox for “An existing post is updated” is not checked it still repost it to Telegram.

    Is there a way to choose to NOT have the “Send to Telegram” checked, so then we would have to manually chose to do so instead of having it post at odd times. A way that would not require custom editing?

    Is there a way to choose to NOT have the “Send to Telegram” checked

    Send to Telegram should automatically turn OFF once the post is sent to Telegram, except in Block Editor which unfortunately doesn’t provide an efficient way to detect that a post has been sent. Otherwise a simple reload should turn it OFF.

    Thread Starter cweb

    (@calebweb)

    Don’t need it to “turn off” after the post is sent, it’s too late by then. You need it to be either turned off by default or the option to not post to choose whether you want private post to post or not.

    Sadly, this default functioning is probably the one part that makes most other parts not worth it.

    We will add an option to choose whether to send private posts or not in the next update.

    After looking into it again, we came to the conclusion that the option will be confusing for the users, so we decided not to add it to the settings page. If you don’t want to send the private posts, please use the code provided above.
    Thanks

    Thread Starter cweb

    (@calebweb)

    LOL! As if your posting of “private” messages be default isn’t already “confusing”!

    Putting custom code is just not a good alternative as it is easily replaced in update.

    You don’t add custom code to the plugin, rather you can add it to functions.php of your child theme. There is also this plugin to add the code easily which will not br replaced by updates.
    https://wordpress.org/plugins/my-custom-functions/

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Private post should not post’ is closed to new replies.