Support » Plugin: Insert Pages » Private Pages Not Selectable

  • Hi,

    Great work on the plugin, I have a question & a functionality request if that’s okay.

    If I make a page and it is set to private, when I am in a different page and I choose to insert the previous private page, it will not show up in the ‘Paste URL or type to search’ drop down list when I start typing it’s name.

    It appears to make the ‘Reveal Private Pages?’ option a bit defunct?

    Let me know if I am doing something wrong here..

    Finally, one irrelevant to the topic request.
    I think it would be great if I could select the default ‘Display’ option.
    As 99% of the time I am using the ‘Content’ Display, I have to tell my clients to select their page, and then select the ‘Display: Content’ setting for the inserted page to show up in the editor.
    I am aware that is very simple stuff, but, for some clients that even starts to get confusing. If they could just type their page name in and then it appeared / rendered as ‘Display: Content’ it would be perfect and much less confusing for them.

    Cheers!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Paul Ryan

    (@figureone)

    We’ll take a look at the private page issue. Can you let us know what role you are seeing this as? And is this on the TinyMCE plugin (Classic Editor), or in Gutenberg?

    Re: default display, this should already be done on a per-user basis. The last display you selected will be used. If you want to override this behavior with a fixed default for all users, you can use the filters described here:
    https://wordpress.org/support/topic/customise-modal-content/

    Thread Starter pmascis

    (@pmascis)

    Hi Paul,

    Sorry I should have mentioned, this is in Gutenberg.

    Oh great! Thanks for that other info I’ll take a look.

    Cheers!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.