[resolved] Private pages are published when edited. (5 posts)

  1. taranes
    Posted 2 years ago #


    I like the plugin, but unfortunately, on each edit, the page's post_status is set to 'publish' -- even for pages which were set to 'private'.

    It would be really helpful, if you could fix the plugin to keep the post_status of the edited page untouched.

    I think the problem stems from file
    function edit_post( $post_data = null ) {
    contains an unconditional
    $post_data['post_status'] = 'publish';

    In my case, I need all wiki pages to be private, so I replaced the assignment to 'private'. Generally, removing that line should (hopefully) yield the wanted result.

    Or -- if that's actually a feature and not a bug -- you could add a switch to the plugins settings, allowing to set the "preferred post_status after edits."



  2. Hi there Tim, @taranes,

    Greetings and thanks for your question.

    Your 100% right here, it is changing the post status, I'll notify the lead developer about this.

    Thanks for your patience.

    Kind Regards

  3. Hi there Tim, (@taranes)

    Hope your well today, sorry about the delay here.

    The lead developer has just pushed a update for this, could you re-download and check it resolves your issue?

    It seems to have worked for me :)

    Thank you!

    Kind Regards

  4. taranes
    Posted 2 years ago #

    Hi Jack,

    a first test was successfull: The post status remained 'private' after saving.

    Thanks for the fix!

    I'll inform you in case I encounter another bug. :-)

    Thanks again and best regards,

  5. WPMU DEV - Your WordPress Team
    WPMU DEV Support Staff
    Plugin Author

    Posted 2 years ago #

    Awesome, thanks for letting us know.

    Have a great day!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Wiki
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic