Support » Plugin: Print-O-Matic » Printing not working in Firefox

  • First of all – great plugin! ๐Ÿ™‚

    But I am having trouble making the print button work in Firefox. It does open the printer-friendly version, but no print dialogue appears. I have made Loom-video showing the problem: https://www.loom.com/share/d5aaec555aa049dbb2a90d5f2d4471b8

    I hope you can help me solve this issue.

    Greetings from Denmark
    Michael Wedebye Pedersen

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor twinpictures

    (@twinpictures)

    Glad you are liking the plugin. Also: nice looking site!
    Very strange with Firefox (and not IE… or Safari, for that matter).
    We will try and recreate the issue on our end and get back with a solution. Hold tight, we are on the case.

    Plugin Contributor twinpictures

    (@twinpictures)

    It seems there is some javascript that is also being included on the print page that might be interfering with launching the print dialogue box.

    We have a rewritten version of this plugin that might address this issue.
    If you would like to give this streamlined release candidate a try, it can be downloaded from GitHub at: https://github.com/baden03/print-o-matic/tree/2.0-redo

    If you want to stick with this version, we are going to have to do some troubleshooting: Try changing the target from the class .postcontent to the ID #postcontent like so:

    [print-me target="#postcontent" title="UDSKRIV OPSKRIFT"/]
    

    Let us know how you get on!

    Thread Starter vismic

    (@vismic)

    Hi Twinpictures

    Thank you so much for responding and looking into my request โ€” and for complimenting my webdesign ๐Ÿ™‚

    The rewritten version of the plugin fixed the issue with the missing print dialogue in Firefox, which is great. But the only issue now is, that the print layout has moved to the left of the page (instead of centered), and 2 columns of text prints vertically and not horizontally (side by side), which they should: https://www.loom.com/share/5d1b98d40e5d44c6a3e7ae71abf54f76

    I have tried to fix this issue with CSS without any luck โ€” and I have moved the CSS-formatting to @media print in the themes CSS-file. I am using Divi-theme, if that makes a difference.

    I hope you can help me resolve this issue

    Thanks in advance ๐Ÿ˜€
    Michael Wedebye Pedersen

    Hi,
    sorry for hijacking this topic but I had exactly the same issue on http://www.vorlagenportal.at your release candidate from github resolved it for me. Hope you include the changes in the next update.

    Thanks again and BR;
    Niko

    Plugin Contributor twinpictures

    (@twinpictures)

    @vismic try adding the following to the quick CSS section of your theme, or the child-theme’s style.css file:

    @media print {
       .et_pb_gutters3 .et_pb_column_1_2, .et_pb_gutters3.et_pb_row .et_pb_column_1_2{
           width: 47.25%;
       }
    }
    

    @nixxxon23 aber klar doch!

    Thread Starter vismic

    (@vismic)

    Thank you very much for the suggestion, unfortunately that didnยดt solve the problem in either browser ๐Ÿ™

    You can see all the styles added to the media print section of my CSS below. Maybe something is clashing with the styles you sent me? There is no styles in Custom Print Page Style on the settings page, since I removed these to the media print styles of the theme.

    @media print {

    #dishName {
    font-size: 40px;
    font-family: ‘Montserrat’, sans-serif;
    font-weight: 800;
    color: #4a3400;
    }

    .recipe-stat {
    font-size: 14px;
    font-family: ‘Montserrat’, Sans-Serif;
    font-weight: 600;
    color: #4a3400;
    margin-bottom: 20px;
    margin-top: 20px;
    }

    h1 {
    font-size: 24px;
    font-family: ‘Montserrat’, Sans-Serif;
    font-weight: 600;
    color: #4a3400;
    }

    ul {
    font-size: 10px;
    font-family: ‘Montserrat’, Sans-Serif;
    font-weight: 400;
    color: #4a3400;
    list-style-type: square;
    list-style-position: inside;
    }

    li {
    text-indent: -1em;
    padding-left: 1em;
    }

    .et_pb_divider_0:before {
    border-top-color: #e09900;
    border-top-width: 2px;
    margin-top: 20px;
    }

    .et_pb_gutters3 .et_pb_column_1_2, .et_pb_gutters3.et_pb_row .et_pb_column_1_2{
    width: 47.25%;
    }
    }

    Hello,
    I have the same problem.
    With divi too and firefox.
    Exemple page

    I have the same problem on following site:
    https://www.yogalehrerausbildung.ch/2020/12/04/die-upanishaden/

    • This reply was modified 1 month, 3 weeks ago by jpkarmatech.

    Hello,
    Is the problem fixed please?
    Thanks !

    Plugin Contributor twinpictures

    (@twinpictures)

    @wpben37 have you tried the 2.0 Release Candidate linked to at the top of this thread?

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.