Support » Plugin: WooCommerce Shipping & Tax » Printing Label is VERY slow

  • Resolved joshmans

    (@joshmans)


    We are able to purchase a label, but it stalls out for about 10 minutes before it brings up the print dialog or gives the option to print/reprint.

    Everything is using current versions, and my PHP version is 7.2.x.

    If there’s anything else you want me to check to help figure this out, let me know. I don’t know if its the USPS API or something else. I did contact USPS and haven’t had much luck.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor danreylop

    (@danreylop)

    Hi Josh,

    We’ve heard about this kind of problem before. Some hosting providers provide a caching server that can interfere with HTTP requests like the “Purchase Label” request. A few months ago we changed the “Purchase Label” request to use “POST” instead of “GET” so it wouldn’t be cached in the most normal hosting configurations.

    What hosting provider are you using? In general, “POST” HTTP requests should never be cached, but maybe your hosting provider has a more aggressive default configuration. The caching server we had problems before is called “Varnish”, maybe you can find its configuration file in your site?

    Plugin Support Jesse Pearson

    (@jessepearson)

    Automattic Happiness Engineer

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

    It is resolved – I had to make exceptions for LiteSpeed caching to not cache anything on the WooCommerce backend. Thanks for the tip!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Printing Label is VERY slow’ is closed to new replies.