WordPress.org

Forums

Primary site alias www (18 posts)

  1. LavishDhand
    Member
    Posted 2 years ago #

    Just set up fresh MultiSite, I want to have my primary site as http://www-example-com. Right now it is http://exapmle-com.

    I don't find any options to fix this.

    Kindly advice

  2. You would have had to when you installed WP before activating multisite.

  3. LavishDhand
    Member
    Posted 2 years ago #

    Hi @ipstenu !

    Thank you for the reply, since my installation is brand new can I disable multisite temporarily and set my primary site with www ?

    Once done I can re-enable multisite, can this attract any problems? I'm concerned regarding database. My understanding/knowledge about databases is almost zero.

    Kind regards

  4. If you remove it properly (all the extra tables) you can enable it again later.
    http://wpmututorials.com/how-to/how-to-disable-multisite/

  5. LavishDhand
    Member
    Posted 2 years ago #

    Hello!

    Thank you again. I'm sorry I forgot to mention my MultiSite installation is wildcard sub domain based with domain mapping.

    I hope this doesn't matter, I was wondering 'www' is also a sub-domain. Kindly confirm whether this can be a problem?

    Kind regards

  6. Doesn't matter, and www is not a subdomain, it's special. :)

  7. LavishDhand
    Member
    Posted 2 years ago #

    I followed everything and ended up with -

    No site defined on this host. If you are the owner of this site, please check Debugging a WordPress Network for help.

    I then completely deleted WordPress and the db. I'm now working with a fresh install and a fresh db.

    Thank you very much for all your help
    Happy New Year :)

  8. LavishDhand
    Member
    Posted 2 years ago #

    Okay, so now I set up my primary site's alias to http://www.example.com. Enabled multiste and I have following error message :

    Warning! Wildcard DNS may not be configured correctly!

    The installer attempted to contact a random hostname (52f99f.www.example.com) on your domain. This resulted in an error message: Couldn't resolve host '52f99f.www.example.com'

    To use a subdomain configuration, you must have a wildcard entry in your DNS. This usually means adding a * hostname record pointing at your web server in your DNS configuration tool.

    You can still use your site but any subdomain you create may not be accessible. If you know your DNS is correct, ignore this message.

    This was not the problem when my primary domain alias was example.com. Also it should be 52f99f.example.com and not 52f99f.www.example.com

    FYI : I'm at Godaddy and I've a dedicated IP address.

    regards

  9. When you installed WordPress, you have to set the home and site URL as http://example.com

    No WWWs in there. Did you do that?

  10. LavishDhand
    Member
    Posted 2 years ago #

    Hello again!
    I hope I'm not annoying you.

    Yes the fresh WP install has it as http://example.com. I'm manually changing 'WordPress Address (URL)' and 'Site Address (URL)' to http://www.example.com.

    Screen shot is here - http://s9.postimage.org/9f518jndr/image.jpg

    Should I not add www here? I can still remove it but then where to define primary site alias?

    I have only taken step 1 on MS install which is to add :
    /* Multisite */
    define('WP_ALLOW_MULTISITE', true);

    I can still revert back as per your guidance.

  11. You should not have www there.

    That's exactly where you need to remove it :)

  12. LavishDhand
    Member
    Posted 2 years ago #

    Hello!

    Yes ok, I'm removing it and once done, it will be default setting but you didn't tell me where do I define 'www' for my primary site then?

    Kindly tell me the secret please, I'm being waited to finish this installation.

    Kind regards

  13. The secret is you don't.

    www is not a subdomain, and it's not something you should have in your site URL for WordPress Multisite. Leave it out, and magically watch your site redirect http://www.domain.com to domain.com

  14. LavishDhand
    Member
    Posted 2 years ago #

    watch your site redirect http://www.domain.com to domain.com

    No, but I want domain.com to http://www.domain.com I want to have www.

    My first installation was already domain.com which I wanted to be http://www.domain.com.

    Your first comment above in this thread said

    You would have had to when you installed WP before activating multisite.

    I would have had to what? Where?

    regards

  15. sallen
    Member
    Posted 2 years ago #

    I did do this and it invloved changing I beleive 5 Mysql tables as well as the wp-cnfig. You are not going to be able to change it through any regular wordpress admin option. It's php my admin, and changing the wp-config.php. look in the wp_blogs, wp_options, wp_site, wp_sitemeta, user_meta tables, if I remember right.

  16. LavishDhand
    Member
    Posted 2 years ago #

    Oh!
    I think I will re-ask my question and I will try to be more simple. Lets assume I have no set up yet. I will start from scratch so here is what I want. A WordPress MultiSite where :

    Primary Site : www-MyPrimarySite-com
    Sub Site 1 : www-alpha-com
    Sub Site 2 : www-beta-com
    Sub Site 3 : www-gamma-com
    and so on..

    All I want is every site (INCLUDING PRIMARY SITE) must start with 'www'. That's all I want.

    ---------------------------------------------------------------------

    In a default installation everything else is fine just primary site is missing 'www'

    Kindly advice me a workaround asap

    We have found that you need 2 domains here ( with and without www) and choose primary as the main website

    No, the domain mapping is not available for Main (Primary) Website of the network.

    Kind regards

  17. I will tell you how, but I want to point something out:

    No, but I want domain.com to http://www.domain.com I want to have www.

    Don't. Seriously there is a reason we suggest you don't, it's just not worth the headache. Sometimes it breaks your wp-admin/network login. I don't know why, I don't know how, but it does. I have ONLY see that problem on www sites. I strongly suggest you not use WWW. It's not needed, it's not required, and it's just making a longer URL. This is the voice of experience.

    If you MUST do that, then:

    1) When you install WP, make the home and site URLs http://www.domain.com
    2) Pick SUBFOLDERS, not subdomains for your subsites
    3) Map per normal

    But again, if you have weird redirect problems in your network admin later on, I will say "I told you so."

    There's a dance that comes with it.

  18. LavishDhand
    Member
    Posted 2 years ago #

    That's what I was looking at, I wish you could have given me this answer a week ago.

    So as per your suggestion I should not use 'www', I respect your experience & advice and I will go with it. I wanted www but only if it came without compromising anything. Thank you very much for your time and support :)

Topic Closed

This topic has been closed to new replies.

About this Topic