WordPress.org

Forums

Thematic
Primary Aside not visible on Thematic home page (2 posts)

  1. madeline_beard
    Member
    Posted 2 years ago #

    I updated my blog to the 1.0.4 version of Thematic today. I am working from a child theme and was able to get most of my formatting issues resolved, however the Primary and Secondary Aside widget areas are still not showing up on the homepage of my site:

    http://seelikeblog.com

    however, when you navigate to another page on the site, it shows up:

    http://seelikeblog.com/about/

    while I am very familiar with customizing for CSS, I do not know a lot about tweaking the PHP. I have searched on forums for others dealing with this same issue and haven't been able to find any discussion, so if anyone has any thoughts, I would greatly appreciate it!

    Thanks!

  2. middlesister
    Member
    Posted 2 years ago #

    If you scroll down the front page, you will see that the sidebar is indeed visible. It has just jumped down beneath the content.

    I recognize this situation. Usually it comes down to an extra closing </div> tag somewhere in a post's content. This leads to incorrect nesting of the html and the layout gets screwed up.

    Check your site in a validator and see for yourself. Here is a quick check. There are several errors of incorrect nesting and one error of missing ending quote. This is a good starting point to fix. The error is not in thematic but in your post's content. The culprit is probably the missing closing quote.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic