Support » Plugin: Rotating Tweets (Twitter widget and shortcode) » Previous/Next or Numbers instead of auto-rotate

  • Resolved adshap8

    (@adshap8)


    First, I just want to say that I love your plugin. Great work.

    I was trying to get the previous/next arrows to work within the plugin according to a previous question below, but can’t get them to work with the “Official Twitter Guidelines” setting. Adding the shortcode by itself works, but the settings can’t be adjusted.

    I would love to see this as a regular option with either the prev/next buttons or numbers (that would match the number of tweets to display). And if this option was checked, it would disable the auto rotate (because auto-rotate can be distracting depending on where it is placed or what kind of WordPress site.)

    And is there a way to adjust the time manually? 6 seconds is too fast and 20 seconds is too slow.

    Thanks for reading! And keep up the excellent work.

    http://wordpress.org/extend/plugins/rotatingtweets/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Martin Tod

    (@mpntod)

    I’ve chucked in a couple of extra short-code options to the development version which should give you more room for customisation.

    So you can now go with something like:

    [rotatingtweets screen_name='twitter' show_meta_next_prev='1' next='next' prev='previous' middot='|' timeout = '0']

    I’ve also put the next/prev buttons in their own <div class="rotatingtweets_nextprev"> so that you can style them as much as you want!

    Have experimented with dots (although not numbers) before and will see what it would take to reactivate this.

    (Also trying to work out why the timeout command isn’t blocking rotation as it should do).

    Plugin Author Martin Tod

    (@mpntod)

    You can also move the next, prev buttons via including:

    np_pos='top'
    np_pos='bottom'
    np_pos='tweets'

    Martin

    I can get all the shortcode working except for the meta_next_prev=’1’code to get the previous next buttons working. They won’t appear. This is the code I was using. Anything I’m doing wrong?

    [rotatingtweets search=’hello’ official_format=’1′ timeout=’12000′ tweet_count=’10’ show_meta_next_prev=’1′]

    Plugin Author Martin Tod

    (@mpntod)

    Apologies. The current coding is for show_meta_prev_next – the instructions I have you were the wrong way round!

    Try:

    [rotatingtweets search='hello' official_format='1' timeout='12000' tweet_count='10' show_meta_prev_next='1']

    Success! That did it. Thank you!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Previous/Next or Numbers instead of auto-rotate’ is closed to new replies.