Support » Fixing WordPress » Previous post link WAS working. Now it’s not.

  • I’ve been running a blog here: for a couple of years.
    I’ve upgraded to WP 2.8.5
    Using the Thesis theme for about a year or so. (version 1.5)
    Everything was working fine. But suddenly this week, only two posts show on the home page of the blog.

    I’ve got “Reading Settings” set for 7 posts per page and that WAS working fine. I’m seeing the 7 posts everywhere EXCEPT on the home page.

    If you click on the “previous entries” link at the bottom of the page, no posts show up.
    If you click the “next entries” link on that page, you go back to the home page and show only 2 entries.

    If you click on the October archive link, you see all the posts for the month, in the archive form. That’s all good.

    I’ve looked for goofy code in the second post. I’ve tried moving that post to a draft. But then a different post shows up in the number 2 spot and everything else does the same (bad) stuff.

    I am not having the double index problem explained here

    Don’t know where to look to solve this.



Viewing 9 replies - 1 through 9 (of 9 total)
  • Thanks Shane
    But I’m not using either of those plugins.
    I’m running only Akismet, cforms 11, google XML Sitemaps, Thesis Open Hook, and WP database backup.

    Or are you suggesting that I should be using them?


    I’m not sure that Shane’s suggestion will help.

    If you examine the source of your Home page, you may see that, although only 2 posts are showing, divs are being generated for 5 other posts – eg:

    `<div class=”teasers_box”>

    <div class=”post-1630 post hentry category-acce category-about-coaching teaser” id=”post-1630″>

    <div class=”post-1618 post hentry category-about-adhd teaser teaser_right” id=”post-1618″>


    But as you can see, they’re empty. Have you upgraded Thesis recently? Or edited any of your custom (child) templates?

    I did see where I had the teasers set to show just 2.
    Problem is, I don’t USE teasers at all.
    Nevertheless, I changed the number of teasers to 0 and then nothing showed on the front page.
    I increased the number of teasers to 5
    More showed on the front page, but still when you click on previous posts, nothing shows. If I click on the archive for the month, everything is as it should be.
    I don’t have any weird settings in post 1630 or 1618
    And I don’t have any custom templates

    I have not updated Thesis
    WordPress is 2.8.5

    Moderator Mark Ratledge


    Forum Moderator

    Prev/next navigation is working in your archives. Try changing to the wordpress default theme for a minute and see if previous/next naviagtion works. If it does, then it’s index.php in Thesis. If it doesn’t, then it’s something with your posts in the database or some other problem….

    Great suggestion.
    I changed themes and the previous/next navigation was working.
    Changed it back and they’re no longer working.

    I’ll check the index.php.. or maybe just upgrade my THESIS theme.

    Especially because NOW, I can’t enable widgets any more.
    I read someplace about clearing cache and restarting FireFox. Did that. Still no widgets.
    Thanks for the help

    Upgraded my thesis theme to 1.6
    Widgets working
    but still no headway on the previous/next navigation on the home page.
    I’ll check with the Thesis people about this and let you know what I found

    Here’s the progress update with some success.
    Go to Thesis Options | Home page display

    Tip: To turn off teasers entirely, simply choose the largest value from the dropdown list below—that way, all your posts will be shown as features.

    This solves the problem of the extra teaser boxes on the home page. Now all the posts show as they are supposed to.

    However, if I set the Display Options | Archives to “Everything’s a teaser,” I get empty teaser boxes again and no content.



    I have this same problem. I have the “Show previous/next post links” checked but they are not showing. If I set the number of featured posts to “4” then 4 will show but no way to see posts prior to those four.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Previous post link WAS working. Now it’s not.’ is closed to new replies.