WordPress.org

Forums

[resolved] 'Previous Entries' link working on Category pages, but not on Main Page? :( (7 posts)

  1. rodeohk
    Member
    Posted 10 years ago #

    Hi guys,

    I have a small problem with my site - whenever I click the 'Previous Entries' link at the bottom of the main page, it takes me to http://localhost:8888/wordpress/wordpress/page/2/, but it turns out to be a 404 page. Changing themes still results in a 404 page, so I'm thinking it's something I altered in my WP root folder.

    The page I really want the 'Previous Entries' link to go to is http://localhost:8888/wordpress/page/2/, not the link above, so how can I change it?

    When I click 'Previous Entries' on my categories pages, it works fine. What did I do?

  2. Chris_K
    Member
    Posted 10 years ago #

    If you go to Options -> General, what are the two URI fields' values?

  3. rodeohk
    Member
    Posted 10 years ago #

  4. rodeohk
    Member
    Posted 10 years ago #

    All of my 'Next Entries' links on the site work fine too.

    EDIT: Actually, it's only the 'Previous Entries' link on the first page that stuffs up. Arghhh.

  5. rodeohk
    Member
    Posted 10 years ago #

    Heh, after looking through five pages of search results:

    In the file: template-functions-links.php
    Find the function: get_pagenum_link($pagenum = 1),
    Change $qstr = $_SERVER['REQUEST_URI'];
    to $qstr = $_POST['REQUEST_URI'];

  6. Chris_K
    Member
    Posted 10 years ago #

    Glad you found something - would you share what your environment is? What web server, OS and php version in particular. Would be useful if someone has similar issues.

  7. rodeohk
    Member
    Posted 10 years ago #

    I'm using MAMP, Version 1.2.1 on Mac OS X.

    http://www.mamp.info/en/home/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags