Support » Fixing WordPress » Previous Entries link in Archive/Category views results in Error 404

  • Recently upgraded to WP1.5 and am using the default template (which I absolutely love!)

    However, I have come across this 404 error which I can not figure out why it happens.

    When clicking on the Previous/Next Entries link from my blog index, the page loads the relevant posts. However, if say I click on a link that takes me to Category A, (example)it will show the most recent posts in the category but when I follow the Previous Entries link, I get a 404 error.

    Same goes with the Archives – selecting January 2005 – page loads with most recent in January but when attempt to view older entries – Error 404 appears.

    Appreciate if someone could assist in figuring out what I haven’t done

    (I have set up so that only 4 posts / entries is shown per page as my entries tend to be long)

Viewing 15 replies - 1 through 15 (of 15 total)
  • I experienced the same problem or a very similar one.

    I’ve been using WordPress for about a year, and have upgraded with quasi-religious fervor each time a new version becomes stable.

    With 1.5 things are better than ever. Yet I noticed a strange thing after this upgrade: at the bottom of my main page, a link marked “Previous entries” pointing to /page/2/ — a page which does not exist on my site. Following said link produced a 404 File Not Found error.

    Did I do something wrong in the upgrade? I didn’t get it. But I perservered. I created a file called “page” and used my .htaccess file to force it into PHP mode. It’s just an include statement, pointing to my index.php file.

    It works, but obviously something ain’t right.

    Can anyone help a brother out? Is there something I misconfigured?

    Just had the same problem with 404 errors in archives and categories pagination in WP1.5. I got to this solution some minutes ago:

    You may have some old ‘RewriteRules’ inserted in your old WP1.2 .htaccess-file to deliver “beautified” URIs instead of those database-driven [path]/index.php?x=15 etc.pp.

    WP1.5 comes with its own ruleset and inserts it automatically into your .htaccess, right at the end of the file. This ruleset is enclosed in comments:

    # BEGIN WordPress … # END WordPress

    Now: Just delete your old rules! (or comment them out) They may be in conflict with those new ones automatically inserted. This solved the problem for me – articles/archive/categories pagination works fine now.

    That did the trick. it was old rules in conflict with new. Thanx, dyingeyes!

    Worked like a charm!.. thank you dyingeyes!

    Serves me right for ignoring this niggling feel that it’s related to htaccess files. I thought I did it correctly the first time.

    I’ve cleared out the old rules, but still getting the previous link and then the 404 error

    I had the same problem, and just like the last poster I still got the error after clearing the .htaccess file and allowing new rules to be created. The .htaccess file had an incorrect rule setup.

    ^category/(.+)/page/?([0-9]{1,})/?$ /index.php?category_name=$1&paged=$2

    ^category/(.+)/page/([0-9]{1,})/?$ /index.php?category_name=$1&paged=$2

    This was in WP 1.5.1 as well.

    Is this resolved in 1.5.1? I’ve not had much luck finding release notes with a exact list of what has been fixed in it.

    OK, in WP 1.5 the error seems to be in wp-includes/classes.php on line 1034. Removing the extra ‘?’ mentioned above on that line seems to fix it. FYI to the coders out here who maintain the software.

    Moderator James Huff


    Volunteer Moderator 🚀

    This has been resolved in WordPress v1.5.1.1. Update now.

    Thank you for the solution, dyingeyes. You will have to still do this even after upgrading to the newest version or delete and recreate the htaccess file.

    Updated to WP v1.5.1.2, and .htaccess deleted and created again by WP, but this problem still remains for me. “Previous entries” in a archive/category view points to a page which does not exist on my site (404 File Not Found error).

    Please, does anyone have this problem? I’ve tried everything (support, trac, codex…) to solve this but doesn’t work.

    New clues. The problem with archive/category which shows an incorrect “Previous entries” (404 error) only occurs when the category listed contains subcategories.

    Any idea?

    Sorry to drag this up from the murky depths, but I’m using WP1.5.2 and I just recently changed the category structure to include subcategories – and voila – I get a ‘previous entries’ link on the last page of entries as described above which goes to a 404.

    Just wondering if there is a fix for this for WP1.5.2?

    I think I read somewhere it’s fixed in WP2 but I’m reluctant to update for now…

    This issue is really killing me, sorry, I don’t mean to bump this but at this point I’m just curious, if there is no fix for this can anyone confirm that it doesn’t happen in WP2?

    Many, many thanks,

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Previous Entries link in Archive/Category views results in Error 404’ is closed to new replies.