WordPress.org

Forums

"Previous Entries" Bug (23 posts)

  1. BuzzLightyear
    Member
    Posted 9 years ago #

    There appears to be a problem on this page of my site.

    On page http://www.greatblighty.com/category/the-arts/

    when I click on "« Previous Entries",

    the link to http://www.greatblighty.com/category/the-arts/page/2/
    gives the error: Not found.

    Any ideas or is this a bug with the software?

  2. You need to upgrade to WordPress v1.5.1.1.

  3. BuzzLightyear
    Member
    Posted 9 years ago #

    Can you confirm this is a specific known bug in the software rather than human error on my part?

  4. Yes, this is (was) a bug with v1.5.

  5. BuzzLightyear
    Member
    Posted 9 years ago #

    I'm a bit anxious about over writing my system files. Firstly I don't want to loose my modified theme and secondly my provider modified some of the system files so that e-mails sent out to new subscibing users arrived from the correct e-mail address. Thing is I don't know what files they changed to do this. I would have thought this facility of setting the e-mail address you want the system to e-mail people with would be part of the interface anyway?

  6. BuzzLightyear
    Member
    Posted 9 years ago #

    I have just completed the upgrade to 1.5.1.1 and it seems to have got fine. My issue stands however with the the "Previous Entries" as detailed above. Any further ideas?

  7. BuzzLightyear
    Member
    Posted 9 years ago #

    Fiddles around but still no further with this ... can anyone help?

  8. For what it's worth, I'm running v1.5.1.1 and have no problems with the previous/next links. In case it helps, here's the code from my main template:

    <div class="navigation">
    <div class="alignleft"><?php posts_nav_link('','','&laquo; Previous Entries') ?></div>
    <div class="alignright"><?php posts_nav_link('','Next Entries &raquo;','') ?></div>
    </div>

  9. mliving
    Member
    Posted 9 years ago #

    I have the exact same problem.

    My Next and Previous links are just huge because of the size of my post titles.

    I just wanted to have <<Previous || Next >> but apparently this is a difficult thing to do because even the last update doesn't seem to fix the problem.

  10. DarylM
    Member
    Posted 9 years ago #

    I'm actually upgraded to 1.5.1.3 and have the same problem though *only* when browsing from the category pages. I can confirm the template code above is correct and present in my theme (which is based on the default).

    I've noticed there are a few topics about this subject in the Support forum, so my feeling is this problem is more widespread than it would seem from just this posting (search forums on : "category previous entries").

    First off, I'm going to try and see if this happens with a theme other than one based on kubrick to see if the problem lies there... if not, then I assume it has something to do with all our rewrite rules as it doesn't seem to happen for everyone.

    My symptoms are that it appears in Category links and in the Archives, but the main page is fine.

    Can anyone else diagnose their issue a bit better ? I'm using the rss feed to keepup to date on this issue here so maybe we can all solve it together.

    ciao !
    Daryl.

  11. DarylM
    Member
    Posted 9 years ago #

    [Followup]
    I've downloaded some different themes, not based on Kubrick, and the problem is definitely not related to thematic or template elements. I'm beginning to think this may have something to do with the rewrite rules on the blog somehow, though not sure... or it may,in fact, be a bug.

    Can anyone post their rewrite rules up here ? Mine appear to be :
    /index.php/archives/%year%/%monthnum%/%day%/%postname%/
    which, as far as I know, is the default.

    I tried changing the category prefix but that led to an outright page not found error on my site (as opposed to in WordPress) which makes me think this may be rewrite related.

    Anyone come up with a solution yet ?

  12. gour
    Member
    Posted 9 years ago #

    Hi!

    I just 'discovered' the erratic behaviour with the "Previous Entries" :-(

    Does anybody know if this is fixed in 1.5.2 (I'm planning to do 1.5.1.3 --> 1.5.2 soon) ?

    Sincerely,
    Gour

  13. circuitor
    Member
    Posted 9 years ago #

    Hi DarylM and all,
    I'm experiencing the same bug. And only with the category pages.
    I'm running a derivative of Kubrick, with WP 1.5.2, and I've recreated the .htaccess file several times.

    Can anyone confirm if this is a documented bug?
    Or do I need to fix something on my end?
    Thanx -yo

  14. moshu
    Member
    Posted 9 years ago #

    If it is a bug - it's a selective one :)
    It works for me on every blog I have or set up for others.

  15. circuitor
    Member
    Posted 9 years ago #

    Moshu-
    You've got the bug on your site too! Go here:
    http://www.transycan.net/blogtest/cat/blog-stuff/page/2/

    And then click "Previous Entries" at the top or bottom of the page.
    You'll get your 404 page.

    The "Previous Entries" links shouldn't even be showing up on that page, y'knw?
    So, is it a bug? Can we work around it?

  16. moshu
    Member
    Posted 9 years ago #

    Oh, I see what you mean :)
    There is no more - that's why it cannot find them. My impression was that it doesn't work for you in any circumstances (i.e. even when there are more posts to show).
    Actually as I see it - WP shouldn't show the "previous" when there are no more posts to show: as it does on the index.

  17. circuitor
    Member
    Posted 9 years ago #

    "Actually as I see it - WP shouldn't show the "previous" when there are no more posts to show: as it does on the index."

    Agreed! I wish it was working that way. Any ideas?

  18. circuitor
    Member
    Posted 9 years ago #

    Found the answer!
    It is a bug and will be fixed for WP version 1.6.

    See the midle of this list here:
    http://codex.wordpress.org/Version_1.6#Themes.2C_Templates_and_Template_Tags

  19. silfani
    Member
    Posted 8 years ago #

    Nope, still there -- running freshy theme on 2.0.3

  20. silfani
    Member
    Posted 8 years ago #

    Figured out what the problem is, I am getting a redundant subfolder call for some reason on every "Previous Entries" link, i.e.,

    yorku.ca/gags/~gags instead of
    yorku.ca/gags/

    If I change the Blog Address in the general options, I can get it to work, but every other link is disrupted. Will look into the theme...

  21. silfani
    Member
    Posted 8 years ago #

    I've gathered from other posts that there is something wrong with how the $index and $qtr strings are being set in lines 394-396 of wp-includes/template_functions_links.php.

    Any ideas? One defines the previous entries link in "manage posts" and the home page ($index), while the other affects category or archives. ($qtr).

  22. silfani
    Member
    Posted 8 years ago #

    Actually, I found that my subdomain wordpress installation is working fine, but my tilda'd site isn't -- so it's definitely something to do with the server redirection... Hmmm..

  23. silfani
    Member
    Posted 8 years ago #

    GOT IT!

    It's ugly but it works. To get rid of the redundant subdomain, just subtract that part of the $index and $qstr strings that is giving the problems.

    To see what they originally were getting, I ran a trace script on the $_SERVER calls in the get_pagenum_link function:


    <?php
    echo $_SERVER['REQUEST_URI'];
    echo $_SERVER['PHP_SELF'];
    ?>

    This gave the orginating file as well as the subdomain. BINGO!

    Thus to lines 377 to 398 of template_functions_links.php, I added a substr php command to excise this problematic subdomain:


    $qstr = wp_specialchars($_SERVER['REQUEST_URI']);
    $qstr = substr ($qstr, 8);
    ...
    $index = $_SERVER['PHP_SELF'];
    $index = substr ($index, 6);

    The discrepancy in the substr calls are because I am getting %7E in $qstr, two characters more than the regular single ~ in $index.

    Thus in general, for $qstr, the number should be the length of subdomain name + 4, and for $index it should be +2.

    This seems to have cleared up other 404 errors originating from the login as well as all instances of previous/next entries misdirection.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags