Support » Plugin: SendPress Newsletters » Preview shows Header, but no content

  • hi folks,

    the “send” preview for my sendpress stopped working. i can see the header image, the background and the links at the bottom etc. just fine, but all the content text is gone. editing the text works fine, but the preview is empty besides the things that are hardcoded into the template php. To be exact, this snippet in simple.php does not seem to run:

    $content = apply_filters(‘the_content’, $post->post_content);
    $content = str_replace(‘]]>’, ‘]]>’, $content);
    echo $content;

    it has worked a month before, now it does not anymore. i installed some plugins after that, but removed them later on (see list below for active plugins). i reinstalled sendpress from a zip to exclude the possibility of file corruption, but it does not help.

    this is not just a preview problem, the sent emails also contain merely the header image, social and unsubscribe links, but no content.

    Do you have any idea what might cause this? thanks in advance,


    WordPress Version: 3.5.1
    SendPress Version: 0.9.4
    PHP Version: 5.2.5-pl1-gentoo
    PHP Memory Limit: 256 MByte
    PHP Memory Used: 24.33 MByte
    MySQL Version: 5.0.44

    Database Tables:
    sve_sendpress_subscribers_event OK
    sve_sendpress_report_url OK
    sve_sendpress_subscribers_status OK
    sve_sendpress_subscribers OK
    sve_sendpress_list_subscribers OK
    sve_sendpress_queue OK

    Port 25: open
    Port 465: open
    Port 587: open


    CodeHighlighter: 1.9
    Custom Posts Per Page: 1.7
    Delightful Downloads: 1.2
    DZS ZoomFolio – WordPress Portfolio: 2.22
    Executable PHP widget: 2.1
    Facebook Fan Box: 1.6
    ggis Inline Post: 1.2
    Insert PHP: 1.1
    Meta Slider: 2.2.1
    Page-Links Plus: Single Page: 2.0
    Page Links To: 2.9.3
    Peter’s Blog URL Shortcodes: 0.4
    Q and A FAQ and Knowledge Base for WordPress:
    SendPress: Email Marketing and Newsletters: 0.9.4
    Table of Contents Plus: 1308
    Wiki Lite: 1.0.8
    WordPress Importer: 0.6.1
    WP-Optimize: 0.9.4
    WP IRC: 1.2
    WP Retina 2x: 1.4.2
    WP UI – Tabs, accordions and more.: 0.8.7
    WP Video Lightbox: 1.6.1



Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author itdoug


    While I cannot guarantee that this is your problem, the first they net jumps out to me is the fact that you are using MySQL 5.0. We don’t officially support MySQL 5.0 because it is so old. There are the few people who have it working, but there are even more who have had issues because they were using MySQL 5.0. As a start, I would recommend upgrading your MySQL version if possible.

    I don’t see any plug-ins on your list that have known compatibility issues, but that doesn’t mean there is not one that has not come across our radar before. You could also try this knowledge base article for troubleshooting plug-in and theme conflicts.

    thank you for your suggestion. unfortunately, i am not at liberty to update the mysql version on the server.

    just as you pointed out, i also cannot see any conflicting plugins in the list.

    I have narrowed it down to apply_filters(). this works:

    $post = get_post();
    	echo $post->post_content;

    but this does not:

    $post = get_post();
    	$content = apply_filters('the_content', $post->post_content);
    	echo $content;

    so i do not think this is a database-related problem.
    the disadvantage of the “working” code is that my shortcodes in the post do not get executed, something which i would probably need apply_filters for… do you have any alternative suggestion how i might get the shortcodes executed?

    thanks in advance

    Plugin Author itdoug


    Perhaps Josh can take a look. Could you provide a screenshot?

    Maybe this will help

    thanks for your reply. i tried re-saving the options and permalink settings, but this did not solve the problem.

    here are the screenshots you requested. 1. editing an email works just fine:

    2. (send-)preview is empty:

    Plugin Author itdoug


    Are you running the latest version now. We’ve updated since you posted your support info.

    yes, i have just updated today before posting the screenshots 5h ago. i am now running SendPress on top of wordpress 3.5.1, the problem remains.

    new update, still not solved. however, now i got some error messages:

    Warning: SendPress::include(/[...]/wp-content/plugins/sendpress/classes/views/class-sendpress-view-emails-send-email.php) [function.SendPress-include]: failed to open stream: No such file or directory in /[...]/wp-content/plugins/sendpress/sendpress.php on line 154
    Warning: SendPress::include() [function.include]: Failed opening '/[...]/wp-content/plugins/sendpress/classes/views/class-sendpress-view-emails-send-email.php' for inclusion (include_path='.:/home/ovh/soft/PEAR:/usr/share/php5') in /[...]/wp-content/plugins/sendpress/sendpress.php on line 154

    and that’s true, i only got


    how come there’s a file missing? I then uninstalled the whole plugin, reinstalled it, the file is still missing.

    Plugin Author Josh Lyford


    Hi Broozar,

    That file is not one we have ever had so it is not missing but i am not sure why it is being loaded either. Did you get that error also on the preview screen? or some where else? it may be an issue with php the version of php you have. I am working to get a test server running with the same version on it.


    steps to reproduce:

    – go to sendpress>emails
    – select one email to send
    – click send
    – do not confirm sending, but select “cancel send”
    – i get 6 error messages, the 2 i posted above 3 times.

    Plugin Author Josh Lyford


    Hi Broozar,

    Thanks for the steps. I am looking into it now.


    whee, the latest update makes the mails appear again! nice work. i managed to modify your simple.php template to match my own style and all is well now.

    thank you for your support!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Preview shows Header, but no content’ is closed to new replies.