Support » Plugin: User Post Gallery - UPG » Preview Settings Layout Not Changing

  • Resolved joshuanan

    (@joshuanan)


    The preview/media template option under Basic Settings > Preview Settings isn’t working. I can deactivate the Lightbox Popup option and switch the template to any other option than basic, but that doesn’t do anything to the preview post. I’ve looked at the code and $all_upg_fields[‘upg_layout’][0] at line 172 of file /wp-content/plugins/wp-upg/wp-upg.php always has the value of ‘basic’ no matter the option I select under Basic Settings > Preview Settings. Obviously, the setting isn’t being updated from that settings page into the database. Please fix this!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author odude

    (@odude)

    This setting will get applied only to the newly submitted post only. The old post will have old layout.
    To update old post into new layout, Go to wp-admin – > User Post Gallery to list all post.
    Select the post to to bulk update/edit, then select the newly assigned preview template.

    Thread Starter joshuanan

    (@joshuanan)

    Thank you! This requirement didn’t seem to be noted anywhere. I suggest it should be noted in some prevalent way on the Layout Designer page so others aren’t as confused about this as I was. I even went so far as to force the displayed version to personal so I could have a download button on the display page (a temporary fix until the plugin is updated again, I know)!

    Thanks again!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Preview Settings Layout Not Changing’ is closed to new replies.