Support » Plugin: MetaSlider » Preview only shows thin white horizontal line

  • Resolved Norm Sash

    (@normsash)



    Multiple themes including 2012
    WP 3.51 multisite
    All plugins disabled except meta Slider 2.1.1

    When I click the preview button I only get a short horizontal strip where the preview should be. I get a spinner in that strip for awhile, then that goes away and the stripe is just blank. However, if I actually go to a page where I’ve inserted the shortcode everything seems to work just fine.

    Any ideas?
    thanks
    -Norm

    http://wordpress.org/extend/plugins/ml-slider/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor matchalabs

    (@matchalabs)

    Hi Norm,

    Good question.. I’ve not seen that one before.

    Which browser are you using?
    What have you set your slideshow size to?
    Does it work if you disable all other plugins?
    Can you send me a link to your site please?

    Regards
    Tom.

    Thanks Tom… I’ve tried this in multiple browsers (IE10, FF, Chrome) and get the same result. I’ve tried modifying the slider properties but don’t see any effect on the preview problem.

    Here’s a screencast of what I’m seeing. http://screencast.com/t/jHauyujO6

    If you send me a pm I’ll send you some login information so you can check it out. email is NormsIM@NormSash.com

    Plugin Contributor matchalabs

    (@matchalabs)

    Hi Norm,

    Thanks for the screencast – that was great 🙂

    Your slideshow height is set to false, it needs to be set to an integer.

    Regards,
    Tom.

    ah, that worked Tom… thanks.

    The reason I had it set to “false” was that I wanted the height to be proportionately figured from the width.

    By having just the width set the height seems to be automatically calculated so that the full picture displays. If I hardcode a height in addition to the width, then some pictures have the top cut off, while others have extra space above or below the pic.

    I don’t know if the intended operation was meant to be that way, but it works great. Sort of like putting 90% in for the image width without specifying height – the frame dynamically adjusts.

    Not sure why it works fine with the shortcode insert, but not with the preview.

    Thanks!
    -Norm

    Plugin Contributor matchalabs

    (@matchalabs)

    Hi Norm,

    The preview isn’t too clever. It looks at the size specified in the width and height fields, and creates a lightbox of the same size. In this case it will be setting the height to 0px.

    Meta Slider was always intended to work with a set width and height, but as you say – it it works, it works 🙂

    One thing you could do is set the width to be wider than your widest slide, and your height to taller than your tallest slide, and uncheck ‘smart crop’. If I’m thinking straight, this should stop the slides from being cropped and you’ll get the height scaling you’re looking for.

    Regards,
    Tom.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Preview only shows thin white horizontal line’ is closed to new replies.