Support » Fixing WordPress » Preview Function returnning “Sorry, no posts matched your criteria.”

  • Okay, so we’ve got a WP install in an IP directory, so the WordPress address (URL) looks like so:

    (And yes, NetworksSolution doth suck big time, yea, verily. The owner of this site cannot move. She thinks.)

    Meanwhile, the Blog address (URL) looks like so:

    This was done by the original owner because she has two urls for one site:


    And NetworksSolutions told her this was the best way to have both URLs point at the .com addy. I don’t know why they didn’t just park and point the .net addy, but nobody ever listens to me.

    Anyway. So all works fine. Going to .net or .com brings up her blog. Everything works great except for the Preview function.

    If she saves a post and then hits “Preview,” she gets a “Sorry, no posts matched your criteria.” This is because the preview addy is thus:

    when it should be:

    Am I explaining this clearly? I hope so!

    She’s been entering the IP addy manually into the URL bar to be able to preview her posts, but is there any way around this?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator Samuel Wood (Otto)

    (@otto42) Admin


    The problem is basically that you’re describing a domain forwarded setup. The herblogname domains are pointing to a server at netsol (EVIL) which does a redirect (or frame hiding) to the actual site at

    WordPress works badly with such a scenario. Domain Forwarding is the combined work of satan and cthulu in the dark abyss where the fires burn eternally. In other words, it should be avoided. 😉

    Best (only) solution:
    1. Use a real host for WordPress.
    2. Point your domain’s A records at this real host.
    3. Dance.

    Okay, Otto, I thank you for your suggestion, but damn. She says her contract expires this fall.

    Is there any other way? Short of summoning the Old Ones?

    I’m not clear how you are handling redirects from the .net to the .com? Is this perhaps an overeager modrewrite problem?

    I have the same error in an install I manage where the blog url is but the wordpress install is at The standard WordPress .htaccess is overeager and doesn’t redirect the ?p=x&preview=true url correctly.

    I’ve seen reports of the same setup and problem as I have, but unfortunately I don’t have a solution yet.

    Msanstx, have you seen this thread? Maybe it will help?

    I don’t know how Network Solutions redirects are handled, either. I’m not up on modrewrite rules so I can’t investigate that part to tell you.

    I CAN tell you her domain and hosting are both managed by Network Solutions.

    In my own sites, my domain registrar is a different company from my webhost. I have my .nets parked and pointed at the .coms. This is something my domain registrar does no fuss no muss.

    My WordPress installs are in the .com directories, never in the webhost’s IP server (or whatever it’s called when you upload directly to the IP addy). I just load my files to .com and my post previews work as they should.

    But her WordPress files were installed into the IP server addy as directed by the NetSol tech guys. They told her it was the best way to do redirects of .nets to .coms.

    I had EXACTLY this problem, with no ugly redirects involved.

    I had just upgraded from 2.3.2 to 2.5.1.

    Going to settings, and making the blog name the same URL as the wordpress name solved the problem. Obviously there is a bug.



    Jawfish is right, it doesn’t have anything to do with your domain redirects, but WordPress’s virtual directory ‘blog address’ handling. Try eliminating that value and see if you can access it from her redirected address.

    in Settings in the administration area, try using this:
    “” instead of this “” and leave the second line blank.

    I don’t think ‘get a real host’ is constructive help. I think many hosts do this or similar redirecting, so the user’s domain root actually points to

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Preview Function returnning “Sorry, no posts matched your criteria.”’ is closed to new replies.