Support » Plugin: WP Job Manager » Preview button does not work

  • Resolved raulstcm

    (@raulstcm)



    Hello, I just installed the add-on and created the three pages. But when creating a job and clicking on the preview button, it takes me to an error page. What could be the problem? Thank you

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor Jen H.

    (@jenhooks)

    Hi @raulstcm,

    What is the exact error that is being reported?

    Have you done any initial troubleshooting yet? If not, please rule out a theme issue or a plugin conflict. I recommend testing things on a staging site rather than on your production (live) site. Many hosts provide a staging service, where you can do testing without affecting the live site. You can ask your host about this. If they don’t give you a staging site, you could try WP Staging or Duplicator:

    https://wordpress.org/plugins/wp-staging/
    https://wordpress.org/plugins/duplicator/

    First, temporarily switch to Twenty Seventeen, which is one of the default WordPress themes. You can do this by installing a plugin that only switches the theme for the current user, linked below:

    https://wordpress.org/plugins/theme-switcha/

    See if the preview step works as it should. If it works when you’re using a default theme, you’ll need to contact your theme’s developer to see if they can help you troubleshoot.

    If things still don’t work properly with Twenty Seventeen, please try checking for conflicting plugins.

    To do so, temporarily disable all plugins but WP Job Manager (and related addons), and see if the issue resolves. If it does, try activating your plugins one-by-one and try to reproduce the problem. If it comes back when you activate a particular plugin, you’ve found the culprit.

    Just a side-note; before you deactivate your plugins, we recommend that you make a full backup of your site.

    Let us know what you find!

    The preview button does not take me to any page, you can check in the following link

    https://www.bikeescuela.com/publica-una-oferta-laboral/

    I tried the parent theme and disabled pluging, but the error continues. I think the problem is that it does not generate a preview or a page is missing.
    The preview button does not take me to any page, you can check in the following link

    https://www.bikeescuela.com/publica-una-oferta-laboral/

    Plugin Contributor Jen H.

    (@jenhooks)

    Hi @raulstcm,

    Can you try going to Settings > Permalinks and click “save”? You don’t need to click anything else there – simply hitting the save button will flush and re-set some rules, which may sort things out automatically.

    Let us know if that does the trick. If not, we’ll keep working on it.

    Hello, I just went to settings, permanent links and clicked on save, but the problmea remains the same.

    Plugin Contributor Jen H.

    (@jenhooks)

    Hi @raulstcm,

    I tried the parent theme and disabled pluging, but the error continues.

    Can you please check this with Twenty Seventeen, one of the default WordPress themes? If you use the plugin I’ve linked below, your visitors won’t see any cange — you will be the only one who sees the theme change.

    https://wordpress.org/plugins/theme-switcha/

    Let us know what you find.

    Hi, I found the problem!
    I work when I disable the plugin WooCommerce Search Plugin by Instant Search +
    Now I will look for something similar to this plugin that is compatible.
    Thank you very much!

    Plugin Contributor Jen H.

    (@jenhooks)

    Hey @raulstcm,

    Nice troubleshooting!

    Let us know when you need us.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.