Support » Plugins » Prevents all comments

  • This locked out all comments on my blog. When I try and submit a comment in a regular install of Firefox with cookies and javascript on, I get the following message.

    Sorry, there was an error. Please enable JavaScript and Cookies in your browser and try again.

    Would be nice if it worked. Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • chris


    Do you have javascript and cookies enabled on your browser? Also, keep in mind that if you are using some sort of plugin or browser feature such as “Private Browsing” in Safari, you won’t be accepting cookies, so be sure all of those type of plugins that block cookies, etc. are off.

    That’s a good response Chris – thanks for sharing that.

    @jacwright: Please be sure to follow the troubleshooting steps listed in the instructions:

    1. If you haven’t yet, please upgrade to the latest version.
    2. Clear your browser’s cache and clear your cookies. Then reload the page.
    3. Make sure JavaScript and cookies are enabled. (JavaScript is different from Java. Java is not required.)
    4. Check the options you have selected to make sure they are not disabling a feature you want to use. If using WP Super Cache, make sure this option is checked to ensure compatibility, and be sure to clear your cached pages after selecting this option.
    5. If have checked these, and still can’t quite get it working, please either post a support request in the comments section of the WP-SpamFree release announcement blog post, or send an email to the address listed in the readme file.

    #5 is especially important, as that’s the proper channel to go through for support requests. I don’t check check this forum that often, but anything that goes through the URL listed in #5 will get answered very quickly. 99% of the support issues I’ve seen so far are due to not following installation instructions. From time to time someone does find a rare bug that is triggered by a particular combination of things, and I usually can fix those pretty quickly and get a new release out with the fix.

    I stopped using this plugin because I had the same experience as jacwright. I liked it until I tried posting a comment myself as a test. I verified that my browser (firefox) had JavaScript and cookies enabled. the plugin gave me an error saying that I needed to have JavaScript and cookies on, that it detected JavaScript, but stated that the server was saying that JavaScript was off. It wouldn’t allow the post. Unfortunately, I had to uninstall it. It shouldn’t need troubleshooting. It should work. people aren’t going to hassle with it, they’re just going to move on, and I don’t have time to work on it myself. Sorry, I know a lot of work went into it.


    The plugin itself doesn’t need Troubleshooting – it’s to help you find out what conflict is causing the overall installation not work. In all of the support requests I get, it’s almost always a conflict from a plugin conflict, improper installation, a mod the author has made to their blog, or something external that’s interfering with the function of the plugin.

    If you need support, the proper channel is to read the documentation and submit a support request directly. This plugin is provided for free – I can’t help you if you don’t follow the proper channels.

    Troubleshooting Guide

    WP-SpamFree Support

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Prevents all comments’ is closed to new replies.