WordPress.org

Support

Support » Themes and Templates » prevent sidebar from reloading on every page?

prevent sidebar from reloading on every page?

  • Site

    I am working on this site and the sidebar is the same on all pages, is there a way (or a better theme maybe?) that would keep the sidebar from reloading for every page.
    All i need is for the content to reload, reloading the sidebar media slows it down.

Viewing 12 replies - 1 through 12 (of 12 total)
  • esmi

    @esmi

    Forum Moderator

    Unlikely. That’s simply not the way in which WordPress themes work.

    I hope this plugin will help you http://wordpress.org/extend/plugins/widget-logic/. this plugin gives you control on widgets

    esmi

    @esmi

    Forum Moderator

    But that won’t remove the sidebar itself. Or stop it re-loading. It just allows you to micro-manage any widgets that have been added to the sidebar.

    Actually you can. You can select the Content/Sidebar template for the static front page and select the Full Width layout globally in theme options.

    select the Content/Sidebar template for the static front page and select the Full Width layout globally in theme options.

    this did not work, my sidebar now appears below the content, and all other pages (with full width layout set in theme options) have no sidebar.

    -I went to the “home” page and set the template to “content/sidebar”
    -under ‘theme options’ i set the layout to “full width”

    all pages (other than ‘home’) are set to default layout

    any idea what i might be doing wrong?

    Try to select 3 layout columns.

    Strike that. There’s actually a bug in the theme.

    In functions.php line 2280 replace is_page_template( 'template-content-sidebar.php' ) with is_page_template( 'template-content-sidebar-half.php' ); then it should work.

    I opened up the functions.php in dreamweaver and did not find that on line 2280 but i did find it on lines 4573 & 4577

    if( 2 == pinboard_get_option( 'layout_columns' ) || is_page_template( 'template-content-sidebar.php' ) )
    
    			$classes[] = 'twocol';
    
    		elseif( 3 == pinboard_get_option( 'layout_columns' ) || <strong>is_page_template( 'template-content-sidebar.php' ) )
    
    			$classes[] = 'threecol';

    ok i realized the line numbers are just different from adding in additional lines, i dont know why its roughly double but i think i get it. Ill try this and get back. thanks

    I just realized you may have misunderstood what im asking- I want the side bar on every page, i just dont need it to reload every time i change the page im one (since its the same).

    In that case what you’re asking for is pretty advanced. It involves loading the content area with AJAX and involves quite a bit of programming.

    In that case you may try this theme:
    http://wordpress.org/extend/themes/ari

    Hope this helps

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘prevent sidebar from reloading on every page?’ is closed to new replies.
Skip to toolbar