Support » Plugin: WordPress Infinite Scroll - Ajax Load More » Prevent scroll go to top after ajax using FILTERS

  • Resolved miguelangeltorresfp

    (@miguelangeltorresfp)


    Hi,
    I’m trying to replicate the Filtering example and everything is working properly but every time I click on a filter, after each ajax call the browser scrolls to top.

    Is there any way I can prevent this behavior ?

    Thank you in advance.

Viewing 7 replies - 1 through 7 (of 7 total)
  • edallison

    (@edallison)

    +1. I am also experiencing this issue.

    Plugin Author dcooney

    (@dcooney)

    Hi @miguelangeltorresfp,
    Do you have the Top of Page setting checked on your Ajax Load More setting screen?

    miguelangeltorresfp

    (@miguelangeltorresfp)

    ok, sorry @dcooney.

    I was not aware of that option.

    Now, it works perfect.

    Thank you very much for your help !!!

    miguelangeltorresfp

    (@miguelangeltorresfp)

    Resolved !!!

    edallison

    (@edallison)

    This actually didn’t solve the issue for me. I’ve tried the Top of Page setting both ways to no avail. Any other suggestions?

    Plugin Author dcooney

    (@dcooney)

    @edallison – Can you share a link to the issue please.
    Thanks,

    edallison

    (@edallison)

    @dcooney – Sorry for the late response. I realized that my issue had to do with my ALM instance being loaded near the bottom of my page. In the process of running $.fn.almFilter, the ‘.alm-listing’ element is cleared then repopulated. Since I had nothing on the page below this, when ‘.alm-listing’ was empty it was moving the viewport above the start of my ALM instance(not necessarily the top of the page).
    The solution that worked for me in this particular case was setting a minimum height on the container element of my ALM instance. This made the filter changes less jarring.

    • This reply was modified 2 years ago by edallison.
Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Prevent scroll go to top after ajax using FILTERS’ is closed to new replies.