Support » Plugin: Easy Digital Downloads » Prevent EDD Thumbnail Goes to /edd folder

  • Resolved erfanmhd

    (@erfanmhd)


    hi,

    is there any way i can prevent EDD Product Thumbnails to upload in wp-content/uploads/edd folder and make them upload to wp-content/uploads just like any other post thumbnail ?

Viewing 15 replies - 1 through 15 (of 18 total)
  • Hi @erfanmhd

    Yes, you can do it but what about the protection of files.

    If we change the path then it will be changed for all types of media including Images, Audio, Video and etc.

    there is a conflict with WebP Express Plugin and EDD Thumbnails.
    The Plugin will replace any tag with <picture> tag and add WebP format of image if brwoser support WebP.

    and cause of EDD Security any thumbnail inside wp-content/uploads/edd will return 403 after plugin replace the thumbnail with WebP format image.

    i taught maybe uploading EDD Thumbnail to wp-content/uploads instead of wp-content/uploads/edd like any other PostType thumbnail would fix the problem.

    Pratik Jain

    (@pratik-jain)

    Hi @erfanmhd

    Can you please provide me the exact extension of the webp image e.g .png?

    403 error is coming because EDD prevents it form loading via .htaccess file put it in the uploads/edd folder.

    If you add your extension in this line in .htaccess then it will work.
    <FilesMatch '\.(jpg|jpeg|png|gif|mp3|ogg)$'>

    So the new line will become
    <FilesMatch '\.(jpg|jpeg|png|gif|mp3|ogg|webp)$'>

    Please try this. I hope this will work for you 🙂

    Works Great!

    Thanks

    erfanmhd

    (@erfanmhd)

    Hi Again,
    i donno why but something is reseting my EDD .htaccess every couple of days.
    is there any way to override this and prevent the auto override so i don’t have to add webp on filematchs every couple of days ?

    Plugin Author mordauk

    (@mordauk)

    You can prevent the file getting reverted by making the changes via this plugin: https://wordpress.org/plugins/easy-digital-downloads-htaccess-editor/

    erfanmhd

    (@erfanmhd)

    @mordauk Thanks bro,
    but that plugin is out of date:
    This plugin hasn’t been tested with the latest 3 major releases of WordPress. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

    and also there is not editor on tools section of wp-admin after activating the plugin!
    is there any way to this by coding trough htaccess file ?

    • This reply was modified 3 months ago by erfanmhd.
    Plugin Author mordauk

    (@mordauk)

    The plugin hasn’t been updated because it hasn’t needed updates. It is still fully compatible and works properly.

    erfanmhd

    (@erfanmhd)

    @mordauk okay but i still can’t see the editor under “Tools” Menu!
    do you have any link of that page ?!

    Plugin Author mordauk

    (@mordauk)

    Are you looking in Downloads > Tools or the top level Tools menu? It should show in Downloads > Tools.

    erfanmhd

    (@erfanmhd)

    Sorry i was expecting it under top-level tools menu!
    i got this message now: The htaccess editor is only useful with the Apache webserver!

    my server is Nginx!

    Plugin Author mordauk

    (@mordauk)

    Ah, in that case the htaccess file won’t do any good and you can’t use it to block files. You will need to create an nginx config instead. See this guide: https://docs.easydigitaldownloads.com/article/682-protected-download-files-on-nginx

    erfanmhd

    (@erfanmhd)

    Thank you for your kind reply!
    i’ve talked to my hosting provider and he informed me that my host is running on lightspeed not Nginx.

    and i need to prevent the edd htaccess file from getting reverted!

    can you think of any other solution for LightSpeed?

    Hi @erfanmhd

    For your query,
    1) I don’t no why but something is resetting my EDD .htaccess every couple of days.
    Ans – This only happens when plugin is activated. It means when you deactivate it and activate it again then it reset your changes in .htaccess file.

    There is another work around and I think it will work for you.

    1) Navigate to your upload directory /wp-content/uploads/
    2) Create a .htaccess file in it.
    3) Put the below content in it.

    Options -Indexes
    <FilesMatch '\.(webp)$'>
    Order Allow,Deny
    Allow from all
    </FilesMatch>

    4) Now check by reactivating the plugin. (Note be sure you have original .htaccess file in /uploads/edd folder)

    I hope this will work for you 🙂

    @pratik-jain Thanks alot man,
    although i didn’t disabled the EDD Plugin at all but the code you gave me works like a charm!

    Cheers ! 😉

Viewing 15 replies - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.