• Resolved jadi100

    (@jadi100)


    Hi,
    under Settings > General Options > Prevent dashboard access I’ve registered all available roles including subscribers, but while logging in e.g. as a subscriber, the black WP admin bar at the top is still showing up. Even when I checkmarked Prevent Core Login its still there. Perhaps the problem has a simple solution. Would be grateful for a hint. Regards.
    (site is still not online)

Viewing 3 replies - 1 through 3 (of 3 total)
  • justano

    (@justano)

    I might be of help.

    The black wp admin bar only shows for logged in users….If a user clicks on the black wp admin bar,it shows “Dashboard” but if they click on”dashboard”,it leads to “my account” (user’s account),not WordPress dashboard.

    • This reply was modified 1 year ago by justano.
    • This reply was modified 1 year ago by justano.
    Deepak Sharma

    (@sharmadpk03)

    Hi @jadi100,

    If you want to remove the black admin bar for certain user roles then you can paste this code into your active theme’s functions.php file.

    //For removing admin bar for subscriber******
    add_action( 'after_setup_theme', 'remove_admin_bar' );
    function remove_admin_bar() {
    if ( current_user_can( 'subscriber' ) ) {
    show_admin_bar( false );
    }
    }
    

    The provided code will remove the admin bar for users with subscriber role.

    Regarding Prevent Core Login, it is an option that you can use to replace default WordPress login with User registration login. You can read more about it here: https://docs.wpeverest.com/docs/user-registration/how-to/how-to-hide-wordpress-default-login-page-and-use-user-registration-login-page/

    I hope this helps.
    Regards!

    Thread Starter jadi100

    (@jadi100)

    Hi sharmadpk03,
    many thanks, it works! Very useful plugin. 5 stars.
    regards

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘prevent dashboard access not working’ is closed to new replies.