Support » Plugin: Contact Form 7 » Prevent contact form spam in WordPress with Akismet

  • Resolved yacinemi

    (@yacinemi)


    Hello
    I just configured a Contact form to use Akismet by entering the akismet:author , akismet:author_email tags.

    [text* your-name akismet:author]
    [email* your-email akismet:author_email]
    [text* your-subject]
    [textarea* your-message]

    Next I typed viagra-test-123 in every field that accepted text:
    your-name = viagra-test-123
    your-email = viagra-test-123@mydomain.tld
    your-subject = viagra-test-123
    your-message = viagra-test-123

    After clicking submit, I received the orange box indicating “THERE WAS AN ERROR TRYING TO SEND YOUR MESSAGE…”, as expected.

    my problem is After removing the value viagra-test-123 from your-name and your-email and your-subject The result was I received the green box indicating that the message was successfully sent. This was not as expected .

    Obviously this is not what we want. If Akismet is only checking the your-name field, this is far from a useful solution. I would appreciate any guidance on how to properly setup the contact forms to check all fields for spam.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    See Spam Filtering with Akismet and Akismet API doc.

    “viagra-test-123” is a special keyword reserved for a testing purpose that is intended to be used in the author name field.

    As explained in the documentation, if you set one of the akismet:* options at least, all of the sender’s input (not only the fields with the akismet:* option) along with related meta-information will be sent to the Akismet API.

    Thank you @takayukister for your explanation
    I want to block messages with external urls except my website domain in the message content

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Prevent contact form spam in WordPress with Akismet’ is closed to new replies.