Support » Fixing WordPress » Prevent Auto Loading Videos

  • I am assisting a client of mine with their WordPress site http://www.msdlawaz.com I have some videos embedded from BrightCove that automatically load when I open the site. If you visit this link http://msdlawaz.com/?page_id=683 you will often find the videos automatically load in the browser and start playing. They SHOULD ONLY play WHEN I CLICK PLAY.

    Is there a way to disable this from happening? Other than manually turning on or installing browser based plugins that block automatic playback of videos? On my computer system (using an Apple Mac with OS X Mavericks and Safari 7) if I load this page in Safari by default the videos are prevented from automatically playing thanks to Safari Power Saving mode. I have to manually start an Adobe Flash session for the videos to be able to play and as soon as I do the videos automatically play. My client mentioned when she goes to the page the videos automatically load for her and would like them to only load when one clicks play. Is there a way to configure this for all users accessing the site – so if anyone visits the page they have to click play to view the videos.

Viewing 7 replies - 1 through 7 (of 7 total)
  • wpismypuppet

    (@wordpressismypuppet)

    Add the “autoStart=false” parameter to the videos…

    http://support.brightcove.com/en/video-cloud/docs/player-configuration-parameters

    I don’t use this service, but all the documentation indicates that by default the players start ‘stopped’ and you have to enable autoplay. With that said, check how you are creating your players…

    Thanks for the tip I’ll try that and report back.

    Okay here are the links to the videos I am trying to embed (I tried using a code on the linked page you mentioned and now the video does not display – perhaps I added the code in the wrong section) by the way one of them has an ad in it – is there a way I can prevent the ad from loading?

    http://www.azcentral.com/video/3199885242001

    http://www.azcentral.com/news/politics/articles/20140212justin-biber-us-deportation-policy.html

    What I have done is load each link for each video and just copy/paste the embed code into a page of the website.

    So for example on the linked video asking if Justin Bieber should be deported I grabbed the following embed code and pasted it as is <object id="flashObj" width="480" height="270" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,47,0"><param name="movie" value="http://c.brightcove.com/services/viewer/federated_f9?isVid=1&isUI=1" /><param name="bgcolor" value="#FFFFFF" /><param name="flashVars" value="videoId=3193555732001&playerID=1659202266001&playerKey=AQ~~,AAAABvZFMzE~,IXjx0MpOF0p74gQ0oxWK0L1cZBcoHPoi&domain=embed&dynamicStreaming=true" /><param name="base" value="http://admin.brightcove.com" /><param name="seamlesstabbing" value="false" /><param name="allowFullScreen" value="true" /><param name="swLiveConnect" value="true" /><param name="allowScriptAccess" value="always" /><embed src="http://c.brightcove.com/services/viewer/federated_f9?isVid=1&isUI=1" bgcolor="#FFFFFF" flashVars="videoId=3193555732001&playerID=1659202266001&playerKey=AQ~~,AAAABvZFMzE~,IXjx0MpOF0p74gQ0oxWK0L1cZBcoHPoi&domain=embed&dynamicStreaming=true" base="http://admin.brightcove.com" name="flashObj" width="480" height="270" seamlesstabbing="false" type="application/x-shockwave-flash" allowFullScreen="true" allowScriptAccess="always" swLiveConnect="true" pluginspage="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash"></embed></object>

    When trying to stop it from auto-loading I inserted the following script or code http://link.brightcove.com/services/player/bcpid2144431163001?bckey=AQ~~,AAABjnKM-Ck~,C_Yw07pWMKQ5_jDw69OsKjmHIIu7o21Z&bctid=2193277789001&autoStart=false in the middle of the below embed code and the video player won’t load then I just get an error message. If I put it at the beginning it appears as text on the page.

    object id="flashObj" width="480" height="270" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,47,0"><param name="movie" value="http://c.brightcove.com/services/viewer/federated_f9?isVid=1&isUI=1" /><param name="bgcolor" value="#FFFFFF" /><param name="flashVars" value="videoId=3193555732001&playerID=1659202266001&playerKey=AQ~~,AAAABvZFMzE~,IXjx0MpOF0p74gQ0oxWK0L1cZBcoHPoi&domain=embed&dynamicStreaming=true" /><param name="base" value="http://admin.brightcove.com" /><param name="seamlesstabbing" value="false" /><param name="allowFullScreen" value="true" /><param name="swLiveConnect" value="true" /><param name="allowScriptAccess" value="always" /><embed src="http://c.brightcove.com/services/viewer/federated_f9?isVid=1&isUI=1" bgcolor="#FFFFFF" flashVars="videoId=3193555732001&playerID=1659202266001&playerKey=AQ~~,AAAABvZFMzE~,IXjx0MpOF0p74gQ0oxWK0L1cZBcoHPoi&domain=embed&dynamicStreaming=true" base="http://admin.brightcove.com" name="flashObj" width="480" height="270" seamlesstabbing="false" type="application/x-shockwave-flash" allowFullScreen="true" allowScriptAccess="always" swLiveConnect="true" pluginspage="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash"></embed></object>

    [Moderator Note: Please post code & markup between backticks or use the code button. Your posted code may now have been permanently damaged by the forum’s parser.]

    Where do I insert the script within the embed code?

    Update: Okay I got the auto-loading of the videos to stop. Thanks for the help! Any ideas also on how to prevent the 2nd video from serving ads when one clicks on the video player to load it?

    wpismypuppet

    (@wordpressismypuppet)

    Glad to see you got the code in the right spot! The ad removal is not something I can help you with. According to what I read:

    http://support.brightcove.com/en/video-cloud/docs/topics/3333

    It looks like it was tagged to allow ads when it was uploaded/created. You should be able to sort through that documentation and play around in the video file itself to find a way to turn off the ad. I don’t have an account of my own, so I can’t see all the options.

    It looks as though there is a checkbox of sorts according to this document:

    http://support.brightcove.com/en/video-cloud/docs/setting-ad-source

    Good luck!

    P.S. I don’t know if it matters to you, but your videos don’t work in IE version 10 and lower…

    Okay thanks for the help. I’ll use those resources you mentioned to try and resolve the ad issue if I can. I had already tried this link but the suggestions there don’t seem to have worked. http://support.brightcove.com/en/video-cloud/docs/player-configuration-parameters-ads and no I don’t think it matters if IE 10 and below are unable to load the videos fully. I am working on this site for a client and am assuming my client is running either a more recent version of IE or another web browser that will support the video playback smoothly and any/all site content. I don’t have an account either on BrightCove but will review the documentation.

    Hello, I am having some problems with my website. It is autoloading all of the Videos at once and you can hear all of them playing when you go to my homepage. I am trying to resolve this. Please go to my website at http://www.hulalime.com and you can email me at suisse2009@aol.com

    Thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Prevent Auto Loading Videos’ is closed to new replies.