Support » Localhost Installs » Pretty Permalinks stopped working for some Multi-site sub-sites.

  • Resolved Justin Fletcher


    Hi guy’s,

    My permalink’s have stopped working for some sub-folder sites of a local WAMP multi-site install, but only some not all ??.

    base network is http://ccc.loc/
    and an example it the “ccconlineold” site and page “contact-us”
    ..which now only works for Permalink Settings = “Default”
    for the Custom Structure =”/%postname%/” it shows no results for the page.

    But it strange that not all the sites are broken?
    one side thought ..would through Network Admin … sites… and editing the site “Path” (ccconlineold) break anything?

    I’ve re-followed the codex advice (Using_Permalinks) but after day’s of trying can’t fix it.
    My setup is as per..
    • Apache 2.2.21
    • Wordpress 3.5
    • All plugins off

    httpd.config …
    # First, we configure the “default” to be a very restrictive set of
    # features.
    <Directory />
    Options FollowSymLinks
    AllowOverride all
    Order deny,allow
    Deny from all

    httpd-vhosts.conf (extract..) …
    NameVirtualHost localhost
    <VirtualHost *:80>
    DocumentRoot C:/wamp/www/
    ServerName localhost

    <VirtualHost *:80>
    ServerAdmin admin@ccc.loc
    DocumentRoot “C:/wamp/www/ccc.loc”
    ServerName ccc.loc
    ServerAlias http://www.ccc.loc
    ErrorLog “ccc.loc-error.log”
    CustomLog “ccc.loc-access.log” common

    Any ideas ?

Viewing 1 replies (of 1 total)
  • Justin Fletcher


    finally found the issue much diggin in and found finally that registering a taxonomy register_taxonomy() from example code with

    'rewrite' => array('slug' => ''),

    and not

    'rewrite' => array('slug' => 'mytaxname'),

    will cause the rewrite rules to miss interpret the first level of pages in the navigation.

    refs that where helpful.. (thanks duck__boy)

    hope it helps others!


Viewing 1 replies (of 1 total)
  • The topic ‘Pretty Permalinks stopped working for some Multi-site sub-sites.’ is closed to new replies.