[resolved] Pretty Permalinks not working after automatic update wordpress 3.8.3 (6 posts)

  1. RicardoLopez
    Posted 2 years ago #

    I suddenly realize that all of my pages are throwing 404 error if my permalink structure is set to post name in my websites on a multisite installation . That's the way it was when this update was done, and I haven't touched it anything. If I set on default, everything works fine as it is, now but no one wants this ugly links . The site is http://maize.org

    My .htaccess looks like this:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [L,R=301]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) projects/$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ projects/$2 [L]
    RewriteRule . index.php [L]

    # END WordPress

    All links worked quite fine with the post name structure before that update, not anymore :(

    I've tried to...
    - Change permission to .htaccess file to 664 even 775
    - Completely delete the .htaccess file and rebuild it
    - Set the permalink structure back to default, then post name and viceversa
    - Create a redirect like: RedirectMatch 301 ^/posts/(.*)$ /?p=$1

    Any help would be really appreciated, I'm not sure what else to try .

  2. Jose Castaneda
    Posted 2 years ago #

    Have you tried to deactivate all plugins? Cleared all caches?

  3. RicardoLopez
    Posted 2 years ago #

    yes, but nothing... even I contacted my host provider (rackspace) without success, they told me that even they found the same trouble when they try it to update to 3.9 in a test environment

  4. RicardoLopez
    Posted 2 years ago #

    Any? I've also updated to wordpress 3.9 =(

  5. Aaron Courtyard
    Posted 2 years ago #

    Same problem. I have also updated to 3.9 now. Still have to update the permalinks a few times a day. the 404's go away for a little while(like 4 hours) then the 404's return.

  6. RicardoLopez
    Posted 2 years ago #

    this is not fully solved but at least is working properly:
    the problem was Sucuri Security - SiteCheck Malware Scanner plugin that working together with WordPress MU Domain Mapping create that 404 error. now what I have to do is:
    if I want to enable permalinks is deactivate all the plugins then activate permalinks, then enable all except Mu domain mapping neither sucuri plugin
    once is done and verify I activate MU domain again... maintaining sucuri plugin disabled.

Topic Closed

This topic has been closed to new replies.

About this Topic