Support » Fixing WordPress » Pretty Permalinks not working

  • Resolved lumena

    (@lumena)



    Hi all,

    I’m tyring to add a folder to the url of my website. e.g:

    http://www.mywebsite.com/recipes
    to
    http://www.mywebsite.com/cooking/recipes

    I have updated the custom permalink structure with /%category%/%postname%/

    I have added the ‘cooking’ category to a page, but nothing is happening. Viewing the recipes page simply displays http://www.mywebsite/recipes.

    I’ve tried many fixes including:

    Checking the .htaccess file for the following code:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    I have set permissions of .htaccess to 666 and 777 with no effect

    I have ensured that mod_rewrite is enabled

    But it still won’t display the category in the URL. Can anyone help??

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hello!

    I don’t think you meant “folder” there…

    By default, pages don’t have categories, posts do. So, if “recipes” is a post, then simply selecting the “cooking” category should give you this URL: mywebsite.com/cooking/recipes.

    If “recipes” is a page, then you have to create a page called “cooking”, and then select the “cooking” page as the Parent of “recipes”. Then you’ll have mywebsite.com/cooking/recipes.

    To do that, go into the “recipes” page, and at the right, at Page Attributes, under the Parent section, press the drop-down menu and select the “cooking” page. Then Save, Update, or Publish.

    Hope this helps you out.

    Oh I see. Yes, categories are completely new to me.

    Thanks Blade!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Pretty Permalinks not working’ is closed to new replies.