WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Pretty permalinks for static pages

[Resolved] Pretty permalinks for static pages

  • cosmocanuck
    Member

    @cosmocanuck

    Hi!

    I can’t figure out what do I need to do to get pretty URLs for my static pages.

    In the Codex article on Pages, it says this:

    “In the above example, the Permalink for the Cameroon Page would be:
    http://example.com/africa/cameroon/

    However in the site I’m working on, page URL’s have this structure:
    http://bizstudio.ca/blog/?page_id=112

    I’d much prefer the former but despite much searching I can’t figure out how to make that happen. I’ve modified the permalink structure under options –> permalinks, but that only seems to affect regular blog entries, not static pages.

    And yes, I’ve looked at http://codex.wordpress.org/Using_Permalinks but I can’t figure out how that applies to my problem… do I have to mess with .htaccess files to do this?

    Thanks!
    adam

Viewing 3 replies - 1 through 3 (of 3 total)
  • moshu
    Member

    @moshu

    but that only seems to affect regular blog entries, not static pages.

    Wrong! Once you set your permalinks to anything other than default – the permalinks for Pages work automatically. You do NOT have to do anything.

    Cal
    Member

    @themesbycal

    Typically I use Custom option under Permalinks and set to

    /%category%/%postname%/

    This also makes my pages look like /pagename

    cosmocanuck
    Member

    @cosmocanuck

    Thanks Moshu, I almost immediately realized after posting this that it was all my fault… I was relying on links I had set up manually within the template, which referenced the page_id, not the “true” link structure which is of course as you say nice and pretty!

    Sorry for posting too soon! Murphy’s Law in action…. sigh…..

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Pretty permalinks for static pages’ is closed to new replies.