Support » Installing WordPress » Pretty permalinks all redirecting to index.php, no one can figure out

  • Ok, updated to 2.8 tonight and now all my %postname% permalinks are getting redirected to index.php 🙁 I have been getting help from scores of people on twitter and no one has been able to help me figure it out.

    This forum thread describes my problem well http://bit.ly/vow1W but that user was able to disable plug-ins and it was solved magically. I have deleted all plug-ins but Akismet and deactivated that it’s still redirecting!

    My htaccess file reads as follows:
    AddHandler application/x-httpd-php4 .php

    # BEGIN WordPress
    Options +FollowSymlinks
    <IfModule mod_rewrite.c>

    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php/ [L]
    </IfModule>

    # END WordPress

    Is there a different way I need to edit that rewrite rule? I tried changing it to RewriteRule . /%postname%/ [L] but that did nothing.

    I’ve changed my permalink settings back and forth, resaving, etc. Nothing is working.

    My URL is http://marshallk.com and I am at the end of my rope. Can someone please help me figure out what happened?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Not sure if this helps or not, but I wonder if it’s this line of code?

    <link rel='index' title='Marshall Kirkpatrick, Technology Journalist' href='http://marshallk.com' />

    I say that because I don’t see it in the header of your cached pages that were working prior to the upgrade.

    At the very least, it might give someone else an idea on what else to troubleshoot.

    <link> tags won’t affect this. It’s not a client issue.

    Marshall: all URLs, including that of your single posts, should be sent to index.php. WordPress then (should) parse the requested URL and serve the appropriate content. It’s not however, for whatever reason.

    Switch to the default theme and see if that fixes it. If not, temporarily switch to the default date-based permalink structure or even disable pretty permalinks altogether. That should help you narrow down the possible causes.

    What happens if you turn permalinks OFF and get rid of the .htaccess file?

    Why are you running it as php4? Even though WP is backward compatible with 4x – php5 is preferred

    and try the default theme (fresh upload from downloaded package) and see if that works

    Viper, i’ve tried both of those. Also happens with any theme 🙁

    I’ve been looking through the WordPress code a little bit and I see that the “wp_rewrite_rules” function could be caching its data in the database in an option called “rewrite_rules”

    Have you been running any sort of caching plugin? If so, you may need to clear that cache (even if the plugin is disabled). See the plugin’s FAQ if this is the case.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Your .htaccess rules (at least, the WordPress part) should look like this:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    Note that that is *exactly* what it should be. No extra / at the end of index.php.

    Also, I see that all your rewrites aren’t working. Try manually re-upgrading your files to 2.8. Just overwrite the existing files with freshly downloaded copies. If the upgrade only half completed, you might see something like this.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Pretty permalinks all redirecting to index.php, no one can figure out’ is closed to new replies.