WordPress.org

Support

Support » Plugins and Hacks » Pretty Link Lite » [Resolved] Pretty Link is not working

[Resolved] Pretty Link is not working

Viewing 10 replies - 1 through 10 (of 10 total)
  • I have an affiliate link:
    http://xxxxxxxxxx.hop.clickbank.net/ and I placed in target URL.

    Under pretty link, I add http://yoursite.com/like/xxxxxxx

    I tick ‘Nofollow’ this Link under SEO option

    Then I go to robots.txt file, I add this, Disallow: /like/

    However, when I go back to my site and click on the button, I still able to see my http://xxxxxxxxxx.hop.clickbank.net/ with my affiliate id.

    Is there anybody able to solve this problem ?

    Thanks.

    Make sure you set your permalinks in wordpress.

    Go to wordpress settings, permalinks, and set the permalink to any option except for “post name”.

    My premalink setting has already been set. However, what I am curious is, I have chosen “custom structure” and hover on the round button, but after I saved. I can see the highlight round button is on “post name”. Is this correct ?

    Maybe your hosting server needs to be cofigured to support .htaccess files.

    What should I do ?

    I don’t think affiliate link has something to do with premalink setting.

    Will it affect ?

    well on most of the servers .htaccess support is already there. on your end, you may first set the permalink structure to default and save the settings. and deactivate and reactviate the plugin

    Before I install pretty link plugin, I have tried quite a number of ways to hide my affiliate link. Let say, using html and cpanel, php redirect and cpanel, so on. The result still the same.

    So I thought of using plugin. However, there is no difference.

    Plugin Author cartpauj

    @cartpauj

    You would need to use a form of “cloaking” to hide the target URL from the browser’s Address Bar. Pretty Link Pro does support cloaking, however many merchants such as Amazon, ClickBank, CJ, etc do not allow, and will detect and break any cloaked links. So be sure to check that cloaking is allowed and works with your merchant before upgrading.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] Pretty Link is not working’ is closed to new replies.
Skip to toolbar