• Resolved kwoodall

    (@kwoodall)


    When Pressforward is active it’s changing the Author Archive links to return a /?p=nnnnn link to some page instead. Yes, I’ve tried multiple themes, turned off all other plugins, etc.

    Help!

    https://nimb.ws/oQ3grG

    • This topic was modified 6 months ago by kwoodall.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Boone Gorges

    (@boonebgorges)

    Are you seeing the same behavior in all places where you’ve got an author archive link, or just in the sidebar area shown in your screenshot? By the looks of your link, you’re using the plugin https://wordpress.org/plugins/wp-post-author/ to create this area. Is that correct? Could you share some more details on just how you set this up so that I can reproduce?

    Thread Starter kwoodall

    (@kwoodall)

    It’s not just in the WP Post Author plugin, I’ve turned back on the theme’s Author Box at the bottom of the post and if you look at View Articles you’ll see the same issue.

    Here is a screenshot of my settings for the widget though. Thanks!!

    https://nimb.ws/8HMvSN

    Plugin Author Boone Gorges

    (@boonebgorges)

    Thanks for the details. I’ll review this as part of the 5.6.0 release. https://github.com/PressForward/pressforward/issues/1175

    Thread Starter kwoodall

    (@kwoodall)

    When is the 5.6 release expected?

    Plugin Author Boone Gorges

    (@boonebgorges)

    Probably sometime in mid- to late-November.

    Thread Starter kwoodall

    (@kwoodall)

    Thanks! Can’t wait for the fix. 🙂

    Plugin Author Boone Gorges

    (@boonebgorges)

    I’ve started to look into this. The functionality is, in part, intentional. There’s a setting at Dashboard > PressForward > Preferences > Site Options called “Show item_author as source”. When set to ‘Yes’, PressForward changes the way that author information is displayed in contexts like your widget:

    • The name of the WP author is replaced with the name of the WP user (post_author) from the source content (stored as ‘item_author’ in postmeta)
    • The author URI is replaced with the URI of the source item.

    So, the immediate question is why, in your specific case the URI is being replaced by the ?p=12345 URI that links right back to the current item.

    I have a feeling it has something to do with the specific way in which you’re using PressForward on your site. PF assumes that you will be pulling content from external sites, either using the Nominate This bookmarklet tool, or by subscribing to the RSS feed. But I suspect that, in your case, you may be importing items into the PF workflow from your own site. Is that correct?

    Alternatively, what we might have here is: You created https://amazingstories.com/2023/10/clubhouse-review-the-sapien-empire-by-nathan-ogloff/ as a regular WP Post (Dashboard > Posts > Add New). This puts it in the same ‘posts’ bucket that PF uses for items that have been promoted through the PF workflow. Is this the case? If so, PF doesn’t really do a good job detecting and accommodating this scenario. I’d say that, when PF detects that a post has been created outside the PF workflow, it should skip the author name/URI filtering, even when the ‘Show item_author…’ setting is ‘yes’. I can probably build something along these lines, but it would be helpful first if you can confirm that this is indeed what’s happening in your case.

    Thread Starter kwoodall

    (@kwoodall)

    It’s the latter. I use The bookmarklet tool to send external posts to the site while many more posts are simply directly posted within WordPress to the site. I don’t use the RSS Feeds at all at the moment.

    But GOOD news. Turning off the “Show item_author as source” fixed the issue!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.