Support » Fixing WordPress » Press75 – Acquisto Theme – cheatin' uh error message when uploading images

  • Resolved BillyWalsh


    I am in the middle of rebuilding my website when I updated to 3.4. I am using the Acquisto theme from

    I am encountering the same problem that so many others describe. I understand claims it is not a problem on their end, so I brought it to the developer’s attention, Jason Schuller.

    After he was unable to replicate the error on his own, the theme and 3.4 apparently works just fine for him, I gave him access to the backend of my website and he took a look to no avail. He was unable to resolve the problem and told me after looking around in the forums it appears to be an issue with the user role definitions.

    He offered no solution or fix though. Needless to say I am VERY disappointed and have already asked for a refund. Not only am I going to have to start from scratch on the rebuild of my website, but I am now going to be hard press to finish the job by the end of July deadline. Awesome.

    Before I scrap this theme I was wondering if anyone out there can suggest a fix to this issue. I know it’s not a problem, but my developer is apparently not offering up any solutions so I am making a last ditch effort here. Please help, anyone. I am going to be bald very soon at this rate of frustration. Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Just a follow up here:

    The Developer Jason Schuller from was actually very helpful and responsive by looking into the matter. Thanks for that, Jason.

    Here is the fix that I found:
    – Deactivate Acquisto theme
    – Completely uninstall Acquisto theme
    – Deactivate Cart66 Plugin
    – Completely remove Cart66 Plugin (From the backend Cpanel!)
    – Reinstall Cart66
    – Activate Cart66
    – Reinstall Acquisto Theme
    – Activate Acquisto Theme
    – Reset Theme Options:
    Appearance –> Theme Options –> Reset Options (bottom left corner of theme options screen)

    Not sure why exactly, and I can’t explain it, but this fixes the issue of receiving the cheatin’ uh error message when trying to use the media uploader.

    Seems like this is a problem that aint going away soon…. In most forums most people think its a theme problem and not a problem within wordpress but after trying many things, testing different themes, and I finally came to the conclusion its a wordpress problem when I tried reversing to previous versions of wordpress while using the same themes everything worked fine. But every time I updated to the new 3.4.1. I experienced the same cheatin uh error.

    Thanks to BillyWalsh I used his method and everything worked fine, though this should be encouraged as a temporary solution. I hope wordpress guys come up with a fix quick.

    Well to fix the error

    1. Login to your plesk/cpanel, whatever you use. Locate

    Open the media-upload.php with the code editor scroll down to line #125 and change the code

    if ( ! empty( $_REQUEST[‘post_id’] ) && ! current_user_can( ‘edit_post’ , $_REQUEST[‘post_id’] ) )


    if ( ! empty( $_REQUEST[‘post_id’] ) && current_user_can( ‘edit_post’ , $_REQUEST[‘post_id’] ) )

    Make sure you don’t touch line 126 with a code that looks like this wp_die( __( ‘Cheatin’ uh?’ ) );—– DON’T TOUCH THIS
    Save and get back to your wordpress admin panel, make sure you have cleared your cache and this should do it. Let me know if you have any other fixes.. Good luck..

    Sorry I meant to say thanks to Thaideas method which helped me. I guess I had BillyWalsh in mind. Wish you the best with the fix..

    Thank you wasjunior… I agree that it isn’t a theme issue.

    The fixed worked for me. I can now upload images. Unfortunately I had to flip back to the original code to upload my ‘feature images’.

    A bit of a pain to flip back and forth but it’s a temporary fix I can handle. Better than no fix at all.

    Now I’m having trouble uploading images to replace my title image. UGH… will these issues ever cease?

    Thanks again.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Press75 – Acquisto Theme – cheatin' uh error message when uploading images’ is closed to new replies.