Support » Fixing WordPress » “Press This” Problems

  • The “Press This” button I installed on my browser’s tool bar to add posts to my WordPress Blog is not working. I have tried using “Press This” on two computers (both a Windows & an Apple computer).

    I am getting a page not found error. The guy that set up my website is able to use the “Press This” feature without a problem.

    Any ideas as to what the problem may be, or how I can fix the problem?


Viewing 6 replies - 1 through 6 (of 6 total)
  • I am also getting this error.

    The Press This Bookmarklet creates a URL like this:

    If I manually change the URL to:

    (removing http://) press-this works correctly.

    I haven’t found a javascript modification, from the many found online, that corrects the error

    I’m running WordPress 2.9.1 on LAMP at Hostgator, installed in a folder called wordpress. My permalink structure is: /%postname%

    Thanks for any help you can offer.

    Here’s a partial fix. I replaced this part of the Press This javascript:


    with this:


    This deletes the http:// from the beginning of the URLs so the script works. It does NOT fix Press This for URLs that start with https:// or other prefixes.

    Interesting… I also am at hostgator, having just moved my blog, and several functions no longer work that used to work at my prior location, including Press This, as well as Link Library and Link This. Unfortunately, I don’t even know where to find the javascript for Press This.

    Any help would be appreciated. Did you ever discuss any of this with Hostgator – or is that just a coincidence?

    Yep – modified the “Link This” bookmarklet along the lines you suggest, and it mostly works now – some problems on finishing the routine – but adds the link as expected.

    Link Library is a much more complicated thing, unfortunately.

    Sorry to be bombarding you here – but I’m also wondering if press-this code has changed too much for 2.9.2 for your fix to work directly on it. The Url seems to be constructed much differently in the press-this file I’m looking at.

    Worked like a charm, Parrothead! Using 3.0 & HostGator. Note that a while back I had to call Hostgator to get this whitelisted for some reason.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘“Press This” Problems’ is closed to new replies.