Support » Plugin: Press This » Press This Not Working With 4.9 Update

  • Resolved deankowalski

    (@deankowalski)


    Press this stopped working with 4.9 update. As I am a content aggregator this bug is devastating. How do I fix?

Viewing 15 replies - 1 through 15 (of 19 total)
  • LCCX

    (@lostcommander)

    I thought is was broken too, but “just” the bookmarklet has been disabled/deprecated. Going to /wp/wp-admin/press-this.php and manually pasting the target URL works for me. Is it more broken than that for you?

    kwoodall

    (@kwoodall)

    Losing the Bookmarklet is devastating. That’s basically the entire reason for Press This is to be able to automatically start a post from a web page you are currently viewing. Otherwise, it’s merely a simplified posting tool.

    Kent McDonald

    (@kent-mcdonald)

    I agree. I just stumbled onto the problem. The previous version automatically loaded the URL of whatever page you were on. Now I have to open press this in a separate tab in order to copy and paste the URL I want. Certainly interrupts the flow for me too.

    dalecameronlowry

    (@dalecameronlowry)

    I’m here for the same reason.

    i follow this problem

    gmaubon

    (@gmaubon)

    Hello, same problem for me. With this stupid decision to extract “press this” functionality from the core, all my news websites are broken … WFT !

    Is there a (safe) way to roll back to the previous version of Press This?

    Same issue, not a fan of the bookmark issue. Press This, come up with a solution.

    • This reply was modified 3 weeks, 6 days ago by  fabbruzzino.

    So much for blindly trusting your “updates”. Please provide a way for those of us who use “press this” on a daily basis to revert to the bookmarklet, which actually is useful, rather that your substitute plugin which serves virtually no purpose at all!

    If there was an easy way to downgrade to the previous WP version, I’d do it in a heartbeat.

    Cannot PressThis from a web page anymore! Help!
    Bookmarklet is extensively used to post to WordPress!
    How do I now PressThis from a web page I want to post?

    Hey- did something change? It seems to be working now. Still a bit awkward with having to copy and paste the url, but at least I’m getting images, title and source now.

    Okay, here’s a workaround.

    Step 1: You need your old bookmarklet back. You can create it yourself, copy and paste from here:

    javascript:var d=document,w=window,e=w.getSelection,k=d.getSelection,x=d.selection,s=(e?e():(k)?k():(x?x.createRange().text:0)),f='http://www.YOURWEBSITEHERE.com/wp-admin/press-this.php',l=d.location,e=encodeURIComponent,u=f+'?u='+e(l.href)+'&t='+e(d.title)+'&s='+e(s)+'&v=4';a=function(){if(!w.open(u,'t','toolbar=0,resizable=1,scrollbars=1,status=1,width=720,height=570'))l.href=u;};if (/Firefox/.test(navigator.userAgent)) setTimeout(a, 0); else a();void(0)

    Yeah, that’s ugly. Note the YOURWEBSITEHERE part.

    Step 2: Go find class-wp-press-this-plugin.php, and comment out lines 1197-1208. That;’s a big if statement

    /*if ( empty( $_GET['_wpnonce'] ) || ! wp_verify_nonce( $_GET['_wpnonce'], 'scan-site' ) ) {
    			foreach ( array( 'u', 's', 't', 'v', '_meta', '_links', '_images', '_embeds' ) as $key ) {
    				if ( ! empty( $_REQUEST[ $key ] ) ) {
    					?>
    					<div class="error"><p>
    						<?php _e( 'The WordPress bookmarklet was deprecated. Please delete it from your web browser.', 'press-this' ); ?>
    					</p></div>
    			 		<?php
                                             return;
    				}
    			}
    		}*/
    

    Works for me.

    ^^
    do not know.. maybe it is a “slightly” copyright protection for other sites?

    • This reply was modified 3 weeks, 5 days ago by  fzzzz.

    robbieslaughter: thank you very much! worked like a charm.

    THANK YOU @robbyslaughter!

    That worked marvelously!

    The bookmark I had made after updating to 4.9 had started directing me to my admin page this morning, and I had got very upset that WordPress would take the “Press This” functionality and _ruin it_

    I am “back in business” and able to post from links to my blog again.

Viewing 15 replies - 1 through 15 (of 19 total)
  • You must be logged in to reply to this topic.