Support » Plugin: PublishPress Permissions: Control Access for Posts, Pages, Categories, Tags » Press Permit 3.3.3 – Page Visibility Problem?

  • Resolved YikYak

    (@yikyak)


    Hi,
    I have a WP multisite, one site has several custom roles and is mainly built with WP pages. The user roles were configured to show particular pages and subsets of the pages nested under them. With the recent PP 3.3.3 update, it seems the users lost access to all pages that were access controlled.
    The site was previously working well for many months/years under the older versions of PP and is still fine if I revert to PP 3.2.5. The site main menu items which are page related are not visible, and direct access to the page URLs also triggers a 404 error.
    I have very few posts and categories, this still seems to work under PP 3.3.3 as before.
    Please can you help?
    YikYak.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Ooops, of course, I meant issue with Publish Press Permissions 3.3.3 – Sorry for my error.

    Hi,

    I experienced the same problem on my multisite installations with PublishPress Permissions 3.3.3 and going back to PPP 3.2.5 eliminated the issue.

    Looking forward eagerly to receiving the next update.

    Plugin Author Kevin Behrens

    (@kevinb)

    @yikyak @dlr-me The following option (intended to allow access to be explicitly blocked at the post level even if granted at the term level) was not previously applied correctly under some configurations:

    Permissions > Settings > Core > “Post-specific Permissions take priority”

    Using version 3.3.3, can you please switch that setting off and let me know if your desired access is restored?

    Plugin Author Kevin Behrens

    (@kevinb)

    @yikyak @dlr-me Please update to version 3.3.4 to restore your access.

    Prior to 3.3.3 the “Post-specific Permissions take priority” setting did not override term-level allowances with post-level restrictions as intended. But the 3.3.3 update caused restrictions to be applied too broadly (with post-level restrictions overriding post-level allowances). The 3.3.4 update straightens that out.

    There is also a new constant definition available to fully restore the pre-3.3.3 behavior (including the ineffective setting) but I don’t think you’ll need it. Feel free to follow up.

    Hi Kevin,
    I didn’t get round to looking at your PPP 3.3.3 proposal.
    PPP 3.3.4 seems to have fixed it for me, I didn’t need to make any adjustments, just update the plugin.
    Thanks for a speedy solution.
    YikYak

    Plugin Contributor stevejburge

    (@stevejburge)

    That’s great to hear, thanks @yikyak

    If you appreciate the support, please leave a review to help keep this plugin moving:
    https://wordpress.org/support/plugin/press-permit-core/reviews/v

    Thank you very much for your invaluable support.

    I updated to 3.3.4 and the access is OK.

    denkster

    (@denkster)

    This issue:
    Post access was improperly blocked under some configurations if Permissions > Settings > Core > “Post-specific Permissions take priority” enabled
    Should have been Fixed: 3.3.4 – 11 Sep 2020

    But it is not fixed properly.
    My users with ‘contributor’ permissions are still locked out, where they had access in version 3.2.5.
    Interesting: users with ‘author’ permissions had access..

    Plugin Author Kevin Behrens

    (@kevinb)

    @denkster Can you let me know if the following constant definition restores your previous results? Add it below other define statements in wp-config.php

    define( 'PP_LEGACY_POST_BLOCKAGE', true );

    denkster

    (@denkster)

    Hi Kevin,
    Thank you for your fast reaction.
    I disabled
    Permissions > Settings > Core > “Post-specific Permissions take priority”
    that seems to help,
    but I have no idea if that did break other functionality.

    I started a consultation of my users to investigate the result.

    I want to see their answers before fiddling with define statements in wp-config.php
    since I have no experience with that kind of things..

    I will let you know.
    Thanks

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.