Presentation Area is showing CSS instead of template info. (20 posts)

  1. JPigford
    Posted 11 years ago #

    For some reason, in the Presentation area of wp-admin it's showing all the CSS for the template instead of the template info like author, description, etc. I have this at the top of style.css

    Theme Name: SiteName
    Theme URI: http://www.website.com/
    Description: Template description
    Version: 1.0
    Author: Josh Pigford
    Author URI: http://www.sabotagemedia.com/

    I've even copied the style.css from the ones that are showing correctly (default and classic) and they do the same thing for this template set. Here's a link to the screenshot:


    Any ideas?

  2. James Huff
    Support Team Rep.
    Posted 11 years ago #

    What browser is that? Firefox?

  3. Mark (podz)
    Support Maven
    Posted 11 years ago #

    Don't use Dreamweaver for your css.
    Download it and edit the comments in Wordpad or something else cheap.

  4. JPigford
    Posted 11 years ago #

    @macmanx - Yes, that's in Firefox but it does that in all browsers

    @podz - I didn't edit it in Dreamweaver

  5. JPigford
    Posted 11 years ago #


  6. Mark (podz)
    Support Maven
    Posted 11 years ago #

    Download your css.
    Open it in Notepad++

    delete the /* and the */

    Replace them.
    Save & upload.


  7. JPigford
    Posted 11 years ago #

    I'm on OSX.

  8. JPigford
    Posted 11 years ago #

    Also, I tried opening it in BBEdit and replacing all the comment tags and I'm still getting the error.

  9. JPigford
    Posted 11 years ago #

    I hate to keep bumping this but I also hate that it's still a problem.

  10. BGreenway
    Posted 11 years ago #

    I'm having a very similar problem, any ideas?

  11. James Huff
    Support Team Rep.
    Posted 11 years ago #

    I also hate that it's still a problem.

    Try reporting the bug so someone can actually work on fixing it:

  12. JPigford
    Posted 11 years ago #

    For those who care and if you to are having this issue, here's where the bug has been reported:


  13. meganano
    Posted 10 years ago #

    JPigford... thanks for escalating this to a bug report. I went to that link and read the whole exchange. I have managed to look at the stylesheets that have been converted by dreamweaver to have line endings but the tutorial that is posted (https://www.kb.indiana.edu/data/agiz.html) is kinda vague as to how to convert the line endings. Can you backchannel me and let me know how you solved the problem? I have only rudminatary UNIX skills or I'm sure I would have figured this out already.

  14. meganano
    Posted 10 years ago #

    Ok. I found a solution finally... after a month of slogging through support forums, the codex and massive trial and error.

    I'm using a mac and have been doing my editing with dreamweaver and my uploading/downloading with fetch. (of course in the process, I've also used transmit, fugu, and cyberduck, which all had the same results.)

    After conducting an exhaustive experiment where I opened a stylesheet in a working theme in mac's textedit, made one change, saved it and re-uploaded it, then did the same thing with dreamweaver, I determined that dreamweaver is doing what was described in Jpigford's trouble ticket, as adding the ^M mac line endings to every line. I was only able to see this after using terminal to view the style.css files using pico.

    To view your file, put it where you can get at it (like the desktop) or drill down in terminal till you get to it. (I won't explain that here, sorry) and type
    pico style.css.
    This will let you view your stylesheet in the pico editor which shows whether or not the proper line endings are there.
    If your stylesheet code is all crammed together with lots of ^M's in there, then you have the problem I did. The next matter was to convert the file before re-uploading it to my webserver.

    This page: https://www.kb.indiana.edu/data/agiz.html
    gave several options for solutions.
    But JUST uploading the already broken files with Fetch or any other FTP client alone did not work as they suggested. (I had already tried that with my previous experiment.) I needed to translate the file in Terminal on my mac.

    I finally did it by going to the directory where the stylesheet exists and typing this in:
    tr '\r' '\n' < style.css > unixstyle.css
    Just for kickes, I viewed the new unixstyle.css file in pico
    and it looked perfect!
    Then, because I am not that skilled with navigating around unix, I went back to the file on the desktop, renamed it style.css (while disposing of the old bad file).
    I then uploaded as a text file using Fetch.

    Voila! It worked.

    No amount of messing with tiny code typos fixed the problem. It's true what some have said, that Dreamweaver breaks the page, but no one had explained exactly how or why. For me at this point, downloading and possibly paying for a new software package isn't an adequate solution. For now, transferring this file before I upload it is a reasonable workaround. I did try to figure out how to adjust the preferences in Dreamweaver to ensure that it saves with the proper line endings, but didn't find anything that seemed to have any effect.

    I hope this helps any of you who have had this same problem.

  15. vkaryl
    Posted 10 years ago #

    Well, some of us wouldn't have had any idea "how" dw breaks the page, since some of us wouldn't let dw on the place, and of course, I don't yet have access to a Mac so wouldn't have been able to test regardless.

    IIRC, I did point out to either you or someone else at one point that the problem was extra white space in the file (I believe I was referring specifically to my own problem of months back, where the extra white space was in the comments section of the style.css file as it happens, but the case remains the same....)

    I would have to agree that transferring is a usable workaround.

  16. meganano
    Posted 10 years ago #

    I came up with another workaround... since I'm still kind of stuck in dreamweaver land for the time being, I chanded the modification permissions (chmod) on the files in my template folder so that I could edit them with directly via the dashboard.
    (dashboard/theme editor).

    I think I changed them to 775.

    Anyways, it seems clumsy, but it's actually less time consuming than my previous workaround. I copy the style out of the window in the dashboard. If I need to use any of dreamweaver's features, I paste it into the stylesheet in dreamweaver, tinker around and then paste the code directly back into the dashboard. It's instantly on the server without the annoying line breaks and I don't have to bother with my ftp client, thus taking a few steps out of the procedure.

    There are I know... other even more streamlined ways to modify stylesheets, but that's what works for me for now.

  17. vkaryl
    Posted 10 years ago #

    Well, as long as it works and is relatively quicker! That's the important thing....

  18. celloboy
    Posted 10 years ago #

    In Dreamweaver MX you can change the line break type in Preferences -> Code Format. I was having this problem and changing the "Line Break Type" to "LF (Linux)" worked for me.

  19. meganano
    Posted 10 years ago #

    Do you mean "LF (Unix)" because I don't have (Linux) as an option.

    I also have "CR LF (Windows)" and "CR (Macintosh"

    I think I already tweaked that. Just wanted to make sure, in case someone else comes along and gets confused.

  20. DrJ
    Posted 10 years ago #

    Yes, switching to 'LF(Unix)' fixes the problem! Thanks celloboy :-)

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.