Support » Plugin: All-in-One Event Calendar » Premium version 1.8.4 available and free 1.8.2 reported broken?

  • As of now, there are 5 reports of “not working” and 2 “working” here in the repository for the version 1.8.2.

    A client’s site that I’m performing maintenance is offering version 1.8.4 premium, compatible with WordPress 3.5.

    I know it’s a free plugin and a very good one, but what is the difference between these versions? Why do I have a non-dismissable admin_notices all over the admin pages offering an upgrade to premium? At least this should be appearing only in /wp-admin/plugins.php. And I’m not quite sure if this conforms to wordpress.org plugin rules (it may fall under 5a of the guidelines)…

    I still haven’t updated to 3.5, maybe a new version of AIOEC is on the road here to the Repository, but some feedback would be very welcomed.
    Thanks.

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

Viewing 4 replies - 1 through 4 (of 4 total)
  • For anyone with the same admin_notices issue, the following hides that:

    add_action( 'admin_footer', 'brsfl_hide_premium_msg' );
    function brsfl_hide_premium_msg() {
    	?>
    	<script type="text/javascript">
    	jQuery(document).ready(function($) {
    		jQuery("div.message.updated.fade:has(p:contains('Premium'))").hide();
    	});
    	</script>
    	<?php
    }

    Sorry but I am a novice in WP. Where does the above code go to resolve the issue with the message?

    @brasofilo thanks for the lead – finally got it upgraded but when I did, it did not resolve the issues 🙂 more research and troubleshooting! Sometimes I feel like I do more ‘tech work’ than development and marketing 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Premium version 1.8.4 available and free 1.8.2 reported broken?’ is closed to new replies.