Support » Plugin: WP Super Cache » Preload: no option to set number of posts

  • I’ve been configuring WP Super Cache on a dozen sites, following the suggestions in the FAQ. Under the Preload tab, there was a select input for wp_cache_preload_posts with a list of all, 24, etc.

    But on two of my sites, that wp_cache_preload_posts is hidden, so I can’t set the number.

    The code on the working ones:

    <p>Preload 
    <select name='wp_cache_preload_posts' size=1>
    <option value='all' selectect=1 >all</option>
    <option value='24' >24</option>
    <option value='48' >48</option>
    ...
    <option value='240' >240</option>
    </select>
     posts.</p>

    On the one that’s not working:

    <input type="hidden" name="wp_cache_preload_posts" value="2" />
    

    I followed almost the exact same sequence of actions in configuring WP Super Cache for all the sites. They are all running WP 4.9.8, PHP 7.2, WP Super Cache 1.6.4.

    Any suggestions? Is this a bug, or am I missing something here?

    Thanks,
    Donna

Viewing 2 replies - 1 through 2 (of 2 total)
  • It’s hidden because number of posts is bellow 100 (WPSC uses SQL query to count posts and maybe there is issue, but I didn’t notice). In this case, default value is ‘all’.

    I’m trying to check the code and I see an issue there. It’s something which should be handled better. We should create new issue on Github (Automattic/wp-super-cache) if it doesn’t exist there.

    Thread Starter Donna McMaster

    (@mcdonna)

    Thanks so much @saša! I should have looked at the code.

    I don’t see any issues on GitHub that seem related, but I’m not sure what is the issue you see. So I will leave that in your hands.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Preload: no option to set number of posts’ is closed to new replies.