Support » Plugin: WP Fastest Cache » Preload does not work in unconfigured DNS WIP site

  • Hello,

    We are migrating from blogger with a custom domain already set.
    So typically while the old site is still live (example.com), we are developing the new site without having changed the nameservers. We have a dedicated IP (185.xx.xx.xxx) so we naturally access our WIP site after editing HOSTS file.

    Under these circumstances I have the following issues with Fastest Cache:

    1. Automatic preload does not work at all. Manual preload gives ERRORS. Apparently, and that’s my only guess, it’s redirected to/looking for the domain (example.com) not the IP 185.xx.xx.xxx.
    2. Cache works if I visit a page, but only as a visitor. If I’m logged in as admin, it does not cache.
    3. If I set any kind of maintenance mode for visitors, cache won’t work. But I guess that’s natural, since it is denied access.

    Is there any way we can get the auto preload to work in this state, before changing DNS and going live?

    • This topic was modified 2 years, 5 months ago by  techsmurfy.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Emre Vona

    (@emrevona)

    1. Automatic preload does not work at all. Manual preload gives ERRORS. Apparently, and that’s my only guess, it’s redirected to/looking for the domain (example.com) not the IP 185.xx.xx.xxx.

    Please contact me via email. http://www.wpfastestcache.com/contact-us/

    2. Cache works if I visit a page, but only as a visitor. If I’m logged in as admin, it does not cache.

    This is a expected result.

    3. If I set any kind of maintenance mode for visitors, cache won’t work. But I guess that’s natural, since it is denied access.

    This is a expected result.

    If anyone has experienced a similar issue about preload not working, please post here, cause we couldn’t resolve it and have no idea what causes it.

    Update:

    Version 0.8.6.4 was giving ERRORS on manual preload.
    Version 0.8.6.6 is only giving “Completed” notice with no errors, but without caching anything.

    Plugin Author Emre Vona

    (@emrevona)

    nice 🙂

    Preload only works if WMPL is disabled.
    The problem lies in the create_preload_cache() function of plugin, which is structured as unable to make good use of the functionality of a virtual directory structure of WPML plugin.
    My site is structured in:
    http://domain-name/ for italian language
    http://domain-name/en for english language (en is virtual directory)
    http://domain-name/fr for french language (fr is virtual directory)
    http://domain-name/es for spanish language (es is virtual directory)

    Thanks for the input. I don’t have WPML enabled, though, and manual or automatic preload still doesn’t work.

    Maybe rewrite rules affect it too? I’m using a couple of plugins for custom permalinks (for parent category removal etc.)

    Btw, updated to the latest version, and the errors are back.

    fastest cache manual preload

    I think in your case the problem can be attributed to the incompatibility between WP FASTEST CACHE and plugins for custom permalink.

    Probably this plugins not working very well.

    You can test it by disabling these plugins and trying preload cache.

    Plugin Author Emre Vona

    (@emrevona)

    I will test with WPML and let you know today.

    I think in your case the problem can be attributed to the incompatibility between WP FASTEST CACHE and plugins for custom permalink.

    Probably this plugins not working very well.

    You can test it by disabling these plugins and trying preload cache.

    No luck. I deactivated all plugins, even switched theme to default, and the preload keeps giving errors.

    I don’t know if the screenshot below helps, my error log is filled with such notices when attempting manual preload.

    fastest cache manual preload errors

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Preload does not work in unconfigured DNS WIP site’ is closed to new replies.