Support » Plugin: WP QuickLaTeX » preg_replace() function is removed in latest PHP 7.* . Need PHP7 compatible code

  • Resolved Sameer

    (@sameernxb)


    Hi Guys,

    The PHP function preg_replace() is used in your plugin which is removed in the latest PHP version 7.*. I have encountered this problem with another Latex plugin due to which all my mathematical formulas and equations vanished right away with a warning that preg_replace is no longer supported. They have given it’s alternate: preg_replace_callback() so we have to use this instead.

    So please let me know do you guys have a plan to update your code so that it is compatible with PHP 7.*. If yes, then when? Because I have clients waiting on this.

    And kindly let me know one more thing, is the plugin compatible with Math-type 6.9 methods?

    Quick response is highly appreciated.

    Thanks,
    Sameer Rajput

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author advanpix

    (@advanpix)

    Hi Sameer,

    Thank you for reporting this issue. We will fix it in next versions of toolbox.
    Plugin is not compatible with MT-6.9 methods.

    Hi Guys,

    Thank you for your quick response. Can you please let me know when is your next release/update expected with this PHP 7 compatibility fix?

    Best Regards,
    Sameer

    Plugin Author advanpix

    (@advanpix)

    This task is of low priority, because this is just a warning.
    PHP 7.* supports preg_replace() perfectly.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘preg_replace() function is removed in latest PHP 7.* . Need PHP7 compatible code’ is closed to new replies.