Support » Plugin: Events Manager » preg_match() with custom permalinks caused by Events Manager

  • I found that I get a couple of messages like these:

    Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in class-wp.php on line 230

    I found during troubleshooting that this is caused by events manager. I can disable events manager, set permalinks to default, then set them again to month + post name and everything works fine. But as soon as I enable events manager, the error is back.

    How can I further debug this issue ?

    https://wordpress.org/plugins/events-manager/

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Support caimin_nwl

    (@caimin_nwl)

    Which version of Events Manager and WordPress are you using?

    The most recent versions: WordPress is at 4.5.3–fr_FR and Events manager at 5.6.5.

    Plugin Support caimin_nwl

    (@caimin_nwl)

    What do you have set under Events > Settings > Pages > Permalink Slugs?

    I did not touch these settings at all.

    So they are set to the default:

    events
    locations
    events/categories
    events/tags

    I did play around with parameters in Events > Settings > Pages > Event Pages and set the ‘Display events as’ to ‘Pages’ and the problem went away. Then I set it back to ‘Posts’ and it did not came back.

    Maybe changing this set some setting where a default was missing after the installation ?

    Plugin Support angelo_nwl

    (@angelo_nwl)

    just to narrow down the problem and help us debug the issue is it possible to try the following temporarily:

    – deactivating all other plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).
    – switching to the default theme to rule out any theme-specific problems

    I’ve taken the following actions:

    1) Verified that the site is running. My test page is ‘access’ a page with some information.
    -> All is well
    2) Enable the extension ‘Events Manager’
    -> I get 7 message pairs like this on most pages:
    Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in /home/clients/27c815ff576fae5bb4bfa5e1322f2d0e/web/wp-includes/class-wp.php on line 231
    Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in /home/clients/27c815ff576fae5bb4bfa5e1322f2d0e/web/wp-includes/class-wp.php on line 232

    3) Disabled *all* plugins
    -> I still get the 7 message pairs like this on most pages:
    Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in /home/clients/27c815ff576fae5bb4bfa5e1322f2d0e/web/wp-includes/class-wp.php on line 231
    Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in /home/clients/27c815ff576fae5bb4bfa5e1322f2d0e/web/wp-includes/class-wp.php on line 232

    4) Enabled the plugins again
    -> I still get the 7 message pairs like this on most pages:
    Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in /home/clients/27c815ff576fae5bb4bfa5e1322f2d0e/web/wp-includes/class-wp.php on line 231
    Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in /home/clients/27c815ff576fae5bb4bfa5e1322f2d0e/web/wp-includes/class-wp.php on line 232

    5) Went to Events > Settings > Pages > Event Pages and set the ‘Display events as’ to ‘Pages’ (was set to ‘Posts’)
    -> All is well, no errors

    6) Went to Events > Settings > Pages > Event Pages and set the ‘Display events as’ to ‘Posts’
    -> All is well, no errors

    Summary
    – Enabling Events Manager somehow created the problem.
    – Disabling all plugins does not eliminate the problem.
    – Fiddling with Events > Settings > Pages > Event Pages -> Display events does fix it, even with Event Manage installed

    Somehow something happens to some data type processed in the loop in class-wp.php around line 23[12] when Events manager is enabled.

    Markus

    Plugin Support caimin_nwl

    (@caimin_nwl)

    Thanks for the info. Can you confirm that you’ve tested with the default WordPress theme (to rule out a theme issue)?

    Hy ,

    I’ve the same issue on my website, I desactivated all my plugin, activate the default theme, then activate event manager and there is the warning :
    http://cms-academy.fr/formations-joomla-lyon-nice-paris/

    Thanks for help

    PS : I also try to delete the plugin, then reinstall it

    Hi !

    Nothing new on this issue ?

    Hi,

    I’m getting the following error: possibly two errors repeating 4 times on all but my home landing page.

    Warning: preg_match(): Unknown modifier ‘/’ in /home4/kharden1970/public_html/wp-includes/class-wp.php on line 231

    Warning: preg_match(): Unknown modifier ‘/’ in /home4/kharden1970/public_html/wp-includes/class-wp.php on line 232

    Warning: preg_match(): Unknown modifier ‘/’ in /home4/kharden1970/public_html/wp-includes/class-wp.php on line 231

    Warning: preg_match(): Unknown modifier ‘/’ in /home4/kharden1970/public_html/wp-includes/class-wp.php on line 232

    I’m getting the following error:

    Warning: preg_match(): Unknown modifier ‘/’ in /home4/kharden1970/public_html/wp-includes/class-wp.php on line 231

    Warning: preg_match(): Unknown modifier ‘/’ in /home4/kharden1970/public_html/wp-includes/class-wp.php on line 232

    Warning: preg_match(): Unknown modifier ‘/’ in /home4/kharden1970/public_html/wp-includes/class-wp.php on line 231

    Warning: preg_match(): Unknown modifier ‘/’ in /home4/kharden1970/public_html/wp-includes/class-wp.php on line 232

    Can anyone help with this? The site was working fine, but this morning after a change to the post/blog menu and post page, I could not undo the problem.

    I had the same error today. Checking all possibilities that have an influence on permalink structure should help.

    e.g.
    – WP permalink settings
    – Yoast SEO permalink setting (category)
    – Events-Manager permalink-settings (was the issue in my case)

    Important: Deactivating or deleting plugins didn’t help. Just open the plugin’s permalink-settings and reconfirm them.

    • This reply was modified 3 years, 6 months ago by Nnet.

    Same problem solved by opening Events plugin settings and, without making any changes, clicking save changes in permalink slug area.

    leighwp,
    Thanks for the tip, I followed your advice and it fixed the preg_match errors on my client website.

    Resaving worked for me too. I don’t know if this helps track down the problem, but I noticed it started to give an error after I made a change in Woocommerce. Specifically I had disabled the New email from being sent under Woocommerce > Settings > Email.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘preg_match() with custom permalinks caused by Events Manager’ is closed to new replies.