Support » Fixing WordPress » "Precondition Failed" Problem. Need help please.

  • Precondition Failed

    The precondition on the request for the URL /prototype/wp-admin/media-upload.php evaluated to false.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I get the above error message whenever I try to insert an image into my page/post. Everything worked fine for months since until about 3 weeks ago. I’ve tried everything I could think of to no avail.

    I have other sites running on 3.2.1 with no image upload/insertion issues.

    Please help.

Viewing 13 replies - 1 through 13 (of 13 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.


    thanks for the response. I’ll try your suggestions and update this post.


    * I’ve tried deactivating all plugins but the problem’s still there – images upload/crunch fully until I click “insert into post”. 🙁

    Going to try switching to the twenty eleven theme now.

    * I’ve tried switching to the twenty eleven theme but no luck.

    Going to try resetting the plugins folder now. 🙁

    * Still no luck after resettig the plugins folder.

    Need help please.

    will upgrading WP help?



    Forum Moderator

    Highly unlikely. This is specific to your site. Have to asked your hosts about this? It could be server config issue.

    server configuration? but it used to work just fine!

    anyways, are there any specific server configurations from the host that could affect WP in this way? I mean, if there’s anything specific I should ask about?



    Forum Moderator

    are there any specific server configurations from the host that could affect WP in this way

    Sorry but that’s like asking how long is a piece of string. There are as many server configurations as there are servers. And it is not uncommon to find different config with the same host. The error message is server-related. It’s not coming from WordPress.

    I’m currently experiencing the same problem with my hosting service. I am pretty certain that it’s a mod_security issue. I’ve vainly tried everything under the Sun to filter the file that exploits the precondition via my .htaccess file. But I recently discovered that there’s nothing I can do myself to resolve the issue. Since v2.5, Mod_security no longer allows for disabling using one’s .htaccess — the httpd.conf must be edited. You need to contact your hosting service tech support and request to have mod_security disabled (i.e., commented out and whitelisting the domain). I hope my hosting service tech support handles this soon! I’ll report back here and give an update.

    Here’s that update. My host indeed disabled mod_security. I am now able to insert images into posts without encountering the HTTP error. I am curious to hear back from @levelsevenltd as to the status of the original problem.

    Hi Mr. Krisha;

    Thank you for your kind replay. this is not others topic it’s my wordpress site problem. even i tried to all ideas given by the members. modification of .htaccess even though its not solved my problem. finally i went to my database and deleted the few entries and again deactivate all the plugins and activate now the problem is solved.

    apart from my hosting server also blocked my system IP address now i am working on it.

    Thank you for your kind help. i need your ideas and support for developing my site in more useful way.




    You seem to misunderstand. Instead of posting your questions on other pages like this, open your own topic so that you will get better attention.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘"Precondition Failed" Problem. Need help please.’ is closed to new replies.