Support » Plugin: Swift Performance Lite » Prebuild not working

  • pmgopal

    (@pmgopal)



    Hi, I am a new swift user. Hosting is with Siteground and I am trying out the lite version on a staging site. Swift caching seems to work well when pages are visited – however I am having trouble getting it to prebuild the cache. Not sure if the cron job is running or not but it doesn’t seem to be doing anything. The cached pages or cache size information doesn’t change unless I specifically visit a page or use manual caching from the url in the table.

    I tried to follow all the best practices – including turning off css/js merging, resetting warmup table, turning off SG Optimizer and Supercacher etc. but still cannot get this to work.

    Appreciate your help.
    Madan

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Fred

    (@fredawd)

    Without exactly seeing the configuration it is difficult to say why the pages are not cached. Maybe a lack of resources that prevents building the cache?

    If you´re not sure if the cron job is running, you could set a cronjob on your server. In Pro version that feauture is available.

    Did you enable Prebuild Cache Automatically?

    Maybe this article is helful
    https://swiftperformance.io/kb/prebuild-cache-is-not-working/

    pmgopal

    (@pmgopal)

    Fred, thanks for the reply. I am running on Siteground GoGeek plan (768M memory). Re Swift, I did enable Prebuild cache automatically and selected almost all the recommended settings from the wizard except combine js, css and lazy load. When I click on the “start prebuid” button, I get a message on top saying it started but nothing else happens. I also enabled the log level to warning to troubleshoot but the logs are empty. I

    I opened a ticket with Siteground as well and they said they don’t see a hosting issue. Here is their response:

    I checked the problem and I believe that the Swift performance plugin is not working properly. It does not seem to update its tables properly. For example, when I tried to reset warmup table, it does not truncate and the number of known pages remains the same. Another thing is that when I tried to manually run one of the cron events shown below:

    https://s.nimbusweb.me/share/2343133/83pftvsodw0k4m0q16lo

    but it remains on the list and it does not get updated.

    I can point you to my instance if you want to take a look. Really appreciate it.
    Madan

    Plugin Contributor Fred

    (@fredawd)

    Warmup table has been already improved, next update will contain the improvement (it will release within a few weeks).

    This should work for now.
    1. disable Enable Remote Prebuild Cache !!!!!!!
    2. delete cache. reset warmup table
    3. delete unwanted URL from the warm-up table

    And you can set a real cronjob. For example
    you can set a real cronjob to visit your (home)page every 12 hours.
    0 */12 * * * wget -q -O - http://www.example.com/ >/dev/null 2>&1

    Hope it helps.

    • This reply was modified 6 days, 5 hours ago by  Fred.

    Thank you Fred.

    Just wanted to confirm that the issue exists with both the pro and the lite versions.

    In terms of the workarounds, #1 does not apply to lite version, and #3 – the removed URLs keep coming back in the table (I did take a look at https://swiftperformance.io/kb/remove-url-option/ but that didn’t help).

    Also, if I understand correctly, the real cronjob is to effectively pre-populate the cache periodically. I should probably use recursive option and to ignore robots.txt to get all the pages.

    Look forward to the updated version of the plugin.
    Madan

    Plugin Contributor Fred

    (@fredawd)

    If you have pro version, just open a support ticket, so we are able to take a closer look into your issue.

    Fred, I wanted to make sure that the functionality works for me before buying the pro version. It looks really good when it works but unfortunately I experienced the prebuild issue right away. Will wait to verify the new version before moving to pro.

    Madan

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Prebuild not working’ is closed to new replies.