Support » Plugin: Prism Syntax Highlighter for WordPress » Pre Tags do not preserve line-breaks.

  • Resolved dirkmittler

    (@dirkmittler)


    Hello.

    I have discovered some problem with my WordPress blog, due to which all code-blocks which were inserted by me for reference purposes, appear on one line, even though I have wrapped each one in a pre tag.

    Not really knowing what has caused this, I next installed your plugin, hoping that to use your plugin will cause the pre tags to preserve the line-breaks.

    But no matter how hard I tried, I was able to get the code highlighted in many ways, with every code-block on one line. I want multiple lines of code to appear on multiple lines in the browser.

    Here is a sample posting of what goes wrong:

    http://dirkmittler.homeip.net/blog/archives/2598

    As I said, all my code blocks are wrapped in pre blocks, yet each incorrectly displays as a one-liner. What am I doing wrong?

    Dirk

    • This topic was modified 5 years, 1 month ago by dirkmittler.
    • This topic was modified 5 years, 1 month ago by dirkmittler.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter dirkmittler

    (@dirkmittler)

    This problem was due to a conflict with another plugin, namely, with the ‘Transposh’ translation plugin.

    It was mainly inattentiveness on my part, which prevented me from discovering this problem until recently. Another reason for which I had not discovered it, was the fact that it never became obvious in my Editing View, not even in the fancy WYSIWYG panel, because no assumption existed that the default-language version of what I was writing there, should be submitted for translation.

    And just today, when I discovered this malfunction, I had tried to remedy it with your plugin, which was unable to do so.

    Your plugin works fine, and can make my code-blocks look much fancier than they would have looked before, on the assumption that anybody had been able to read them before. πŸ™‚

    Dirk

    I have seen your post, I guess something generated some not properly closed HTML, I would have suggested disabling “enable translate in default language” but whatever πŸ˜‰

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Pre Tags do not preserve line-breaks.’ is closed to new replies.