Support » Plugin: qTranslate X » Pre-path mode leads to error 404

  • Resolved Fiable.biz

    (@fiablebiz)


    Hello.

    I installed HotThemes’ “kindergarten” theme.
    http://hot-themes.com/wordpress/themes/kindergarten
    In qTranslate-X settings, I chose “Use Pre-Path Mode (Default, puts /en/ in front of URL). SEO friendly.”, and I clicked on that hyperlink : “If you have installed qTranslate for the first time on a WordPress with existing posts, you can either go through all your posts manually and save them in the correct language or click here to mark all existing posts as written in the default language.”. Then I visited the site, was redirected, as expected, to http://myhome/en/ and got… “Error 404”.
    HotThemes refused to help.
    Is there any way to make that theme work with qTranslate-X?

    https://wordpress.org/plugins/qtranslate-x/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Gunu

    (@grafcom)

    @Fiable.biz

    please switch the theme to a standard one, for example, to the “twentyfourteen”, and see if the problem still exists.

    Thank you. We reinstalled the package (which includes WordPress itself) from scratch, and tried again: the same problem occured. Changing the theme to “Twenty Fifteen” doesn’t solve the problem. The other active plugings are:

    • Hot effects rotator
    • Hot full carousel
    • Hot gallery
    • Hot lightbox
    • Hot maps
    • Simple local avatars
    • Title remover

    All were included in “kindergarten” package, except the last one.

    Plugin Author Gunu

    (@grafcom)

    @Fiable.biz

    what does Title remover?

    Can you give me a link to your site?

    if you want to keep it private use:
    gu nu at mar ius – si roen d com

    Thank you for your very quick answer. We’re quite new to WordPress, coming from Drupal. If I understand well this ecosystem, comparing qTranslate-X with HotThemes, the less you pay, the better is the service. 😉

    Title remover is there:
    https://wordpress.org/plugins/title-remover
    So far, our site is only local. I would prefer to solve the problem before putting the site alive.

    Plugin Author Gunu

    (@grafcom)

    @Fiable.biz

    deactivate all other plugins and see if that makes a difference.

    Then activate them one at a time to see where it goes wrong.

    Deactivating all these plugins have no positive effect!
    The site is now on line there:
    http://myhome-cicm.org
    but without the option “Use Pre-Path Mode”.

    Plugin Author Gunu

    (@grafcom)

    @Fiable.biz

    go to Settings – Permalinks – choose Post name and Save Changes.

    post here the content of your htaccess file

    Plugin Author Gunu

    (@grafcom)

    @Fiable.biz

    I see you’ve solved it right?
    So I close this topic.

    You can always still respond

    Thank you very much indeed! But where is this piece of information? I can’t see it on page
    https://wordpress.org/plugins/qtranslate-x/installation

    Plugin Author Gunu

    (@grafcom)

    @Fiable.biz

    But where is this piece of information?

    What information do you mean exactly?

    The fact that I should have gone to Settings – Permalinks – chosen “Post name” and “Save Changes”.

    Plugin Author Gunu

    (@grafcom)

    @Fiable.biz

    because it would do automatically when you change the path settings in qTranslate X….

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Pre-path mode leads to error 404’ is closed to new replies.