Support » Plugin: SyntaxHighlighter Evolved » pre markup support

  • aurelienpierre

    (@aurelienpierre)


    Hi,

    I used for almost a decade Crayon Syntax Highlighter. I had to disable it a couple of months ago due to incompatibilities and bugs.

    Therefore, I have 10 years worth of posts archives using snippets formatted with markup like <pre class="lang:sh decode:true">. The current plugin doesn’t format them.

    To give context, I’m writing scientific kind of posts in a Markdown/LaTeX way (separate layout and content, single column of text, nobody ain’t time for mouse). Gutenberg blocks are a no-go for me, as well as plugin-centric shortcodes that will be made useless if I need/choose to switch plugin.

    Is there a way to make pre markup properly decoded by SyntaxHighlighter ?

Viewing 1 replies (of 1 total)
  • Plugin Author Renatho

    (@renathoc)

    Hi @aurelienpierre!

    I thought about how you could solve your problem and I have an idea for you. I found this plugin: https://br.wordpress.org/plugins/search-and-replace/

    I’m not familiar with this plugin, so I recommend you make a backup before installing it.

    With it, you could replace your tags in all of your posts. You would have to make 2 searches and replace:

    1) From <pre class="lang:sh decode:true"> to [code language="latex"]
    2) From /pre> to /code]

    So, you'll be able to convert all occurrences of the <pre> to the SyntaxHighlighter Evolved shortcode.

    • This reply was modified 11 months ago by Renatho.
    • This reply was modified 11 months ago by Renatho.
    • This reply was modified 11 months ago by Renatho.
    • This reply was modified 11 months ago by Renatho.
    • This reply was modified 11 months ago by Renatho.
    • This reply was modified 11 months ago by Renatho.
Viewing 1 replies (of 1 total)
  • The topic ‘pre markup support’ is closed to new replies.