Support » Plugin: WP Add Mime Types » PPTX not working

  • I am trying to add pptx. I have entered them into the Add values box and they appear there. But still I am unable to add the pptx file. Security error, unable to upload still comes. Where am I missing? I do not have any other mime plugin installed.

    The values I have added.

    pptx = application/vnd.openxmlformats-officedocument.presentationml.presentation
    pot|pps|ppt = application/vnd.ms-powerpoint

    Help me out.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author kimipooh

    (@kimipooh)

    I think that this trouble is WordPress 4.7.1 issue.
    Please tentatively set up the following setting in wp-config.php file until the fix or WordPress core file.

    define( ‘ALLOW_UNFILTERED_UPLOADS’, true );

    Reference: https://wordpress.org/support/topic/wp-4-7-1-kills-svg/page/3/

    Plugin Author kimipooh

    (@kimipooh)

    I checked this issue.
    WordPress 4.7.1 added strong file type check system using finfo_file function.

    If you PPT file extension (.ppt) changed .pptx, the new system blocks the upload.

    Thus, please try to new PPTX file created by PPTPX file format.
    I succeeded to upload my PPTPX file.

    Plugin Author kimipooh

    (@kimipooh)

    New version (2.1.0) was released for fixing this issue.

    In case of setting up custom extensions in this plugin’s setting, WordPress 4.7.1 file contents check system using finfo_file function is always ignored.

    If you want to upload a file which cannot be uploaded due to the permission is not, please set up the file extension in the plugin setting.

    ex.
    pptpx = application/vnd.openxmlformats-officedocument.presentationml.presentation

    miken

    (@miknegami)

    Hi kimipooh,

    I’m using WP Add Mime Types 2.1.0 and WordPress 4.7.1.
    I’m trying to upload xlsm file, but it has been unsuccessful.

    xlsm = application/vnd.ms-excel.sheet.macroEnabled.12

    I can upload xlsx, but not xlsm.

    Can you check this for me and give me a solution?
    Thank you very much in advance.

    Mike

    • This reply was modified 11 months ago by  miken.
    Aaron Brown

    (@web-malama)

    Same for me. XLSM will not upload, using WP Add Mime Types 2.1.0 and WordPress 4.7.1. Adding the following code to wp-config.php file makes it work, but creates a security hole–as you know.

    define( ‘ALLOW_UNFILTERED_UPLOADS’, true );

    Plugin Author kimipooh

    (@kimipooh)

    This reason is the new mime check system in WP 4.7.1.
    The check system uses finfo_file function, so it says that a xlsm file cannot detect (on my MacBookAir).
    Thus,a xlsm file cannot upload on WP 4.7.1 for the security reason.

    To avoid this check system, please set up the xlsm setting in the plugin setting.

    ex.
    xlsm = application/vnd.ms-excel.sheet.macroEnabled.12

    Plugin Author kimipooh

    (@kimipooh)

    There is the bug of the check system for the WP registered mime types in this plugin version 2.1.0. Please update 2.1.1.

    miken

    (@miknegami)

    Hi Kimipooh,

    Thank you very much for your prompt reply.

    I updated to 2.1.1. I checked the plugin settings and it seems that as default, ‘xlsm = application/vnd.ms-excel.sheet.macroEnabled.12’ is set up. I made sure that none of the other mime type plugins are activated.

    Sadly, I’ve still been unsuccessful to upload my xlsm file.
    If you can check it again, I’d appreciate it.

    Thank you,
    Mike

    Plugin Author kimipooh

    (@kimipooh)

    WP 4.7.1 blocks to update some default extensions, such as pdf and xlsm.
    (Bug report: https://core.trac.wordpress.org/ticket/39550)

    To avoid this issue, you need to add the same setting in this plugin setting or adds define( ‘ALLOW_UNFILTERED_UPLOADS’, true ); to wp-config.php.

    In case of adding ‘xlsm = application/vnd.ms-excel.sheet.macroEnabled.12’ in this plugin setting, the plugin will avoid WP 4.7.1 content check system.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘PPTX not working’ is closed to new replies.