Support » Themes and Templates » <p><p> problem when validating

  • Hi!
    I try to get my blog xhtml 1.0 strict validated, but after hours of crunching small bugs I still can not seem to fix this. It is in the <? the_content(); ?> or content generation…I searched the forum and found others that have had the same issue, but the solution of commenting out the:
    11: //add_filter(‘the_content’, ‘wpautop’);
    in the template_function_post.php file does not have any effect. Tried to turn off the option in the admin-panel.
    cut’n’paste from the validation
    ———————————————————————————————————–
    < p >< p >Fredag 24.Sept 2004 var det duket for den første middagen i Gourm
    etc
    etc for all my stories
    ———————————————————————————————————-
    I am using the 1.2 version. Any ideas or tips would be greatly appreciated!
    cheers
    js

Viewing 9 replies - 1 through 9 (of 9 total)
  • Look at this post and see if that gives you any ideas or post that section of your code here and let’s take a look.

    Are you entering text on the WordPress write screen or pasting it from another editor?
    Are you using any plugins or applied any hacks (your own or others)?
    What version of WP?

    Hi dennis.
    I am using another texteditor..textpad is my choice 😉 And yes I am running a lot of plugins, and have made some adjustments myself, but not to the major WP functions like “the_content” or ” get_the_content”…So I do not think that is it….It’s all very strange. 🙂 I am reviewen all the templates files related to the content…but can not seem to find an error..The WP version is 1.2…

    Perhaps the soultion is just to write a function that slices of 3 caracthers in front and end of the content output…It is a bit quick’n’dirty, but it might just do the trick…what do you think?

    Have you tried entering a post directly into WP and seeing if that has the extra tags?
    Other than that, one of the plugins just about has to be the one touching the post on the way in or the way out.
    I don’t know.

    OH, I thought meant the code…all post are written in wp…hmm, so you mean I should try to deactived all the plugins one-by-one to see? hmm, I will have to look into that this evening. I saw that the guy from the other post did not solve his problem neighter…perhaps a “chop_chop_content” function is my best chance of making my page validate…

    edge2edge: I had the same problem and had to disable Markdown and Textile plugins. I think it had something to do with me manually entering the paragraphs so that I can apply classes to them in my posts. I recon that those two plugins also automatically put paragraph tags in the start of the post.

    Aha, that was it! Thanks Fernando…deavtivated the Markdown plugin…and SWISH everthing was ok! Now that I know what caused it, I will dive into the Markdown plugin!
    You made my day!
    Cheers

    No problem. I’m glad my own headaches could save people from their own.
    😉

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.